libsigcxx: Update to 2.10.1
authorRosen Penev <rosenp@gmail.com>
Fri, 14 Dec 2018 19:49:31 +0000 (11:49 -0800)
committerRosen Penev <rosenp@gmail.com>
Sat, 15 Dec 2018 04:48:20 +0000 (20:48 -0800)
Size goes from 15613 to 8427 bytes.

2.10.1 is the latest version. Version 2.99.x is the unstable series.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libsigc++/Makefile
libs/libsigc++/patches/001-no_doc_tests_examples.patch [deleted file]

index f7ad98816bd9a159ca637d7ef8aaa9800d5158c6..e86753eb9bd40f6ce66b01884e0f3d5da0929789 100644 (file)
@@ -8,16 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsigc++
-PKG_VERSION:=2.5.4
+PKG_VERSION:=2.10.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=@GNOME/libsigc++/2.5
-PKG_HASH:=ecf55f53d6058ba6e41985b862f2e95fb5c2b31c008caa16984e790547337ea7
-PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
-PKG_LICENSE:=LGPL-2.1
+PKG_SOURCE_URL:=@GNOME/libsigc++/2.10
+PKG_HASH:=c9a25f26178c6cbb147f9904d8c533b5a5c5111a41ac2eb781eb734eea446003
+
+PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
+PKG_LICENSE:=LGPL-3.0+
+PKG_LICENSE_FILES:=COPYING
 
 PKG_FIXUP:=autoreconf
+PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -36,14 +39,13 @@ define Package/libsigcxx/description
  whether it is static or virtual.
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
-TARGET_CPPFLAGS +=  \
-       -fno-strict-aliasing -fno-inline \
-
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
+       --disable-benchmark \
+       --disable-documentation \
+       --disable-deprecated-api \
+       --disable-warnings
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
diff --git a/libs/libsigc++/patches/001-no_doc_tests_examples.patch b/libs/libsigc++/patches/001-no_doc_tests_examples.patch
deleted file mode 100644 (file)
index f2c22c3..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -22,7 +22,7 @@ doc_subdirs = docs
- else
- doc_subdirs =
- endif
--SUBDIRS = sigc++ tests examples $(doc_subdirs)
-+SUBDIRS = sigc++
- sigc_configdir = $(libdir)/$(SIGCXX_MODULE_NAME)/include
- nodist_sigc_config_HEADERS = sigc++config.h
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -204,7 +204,7 @@ am__define_uniq_tagged_files = \
- ETAGS = etags
- CTAGS = ctags
- CSCOPE = cscope
--DIST_SUBDIRS = sigc++ tests examples docs
-+DIST_SUBDIRS = sigc++
- DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
- distdir = $(PACKAGE)-$(VERSION)
- top_distdir = $(distdir)