projects
/
openwrt
/
svn-archive
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8c34673
)
create /lib/modules dir only when necessary
author
Nicolas Thill
<nico@openwrt.org>
Fri, 11 Nov 2005 17:36:11 +0000
(17:36 +0000)
committer
Nicolas Thill
<nico@openwrt.org>
Fri, 11 Nov 2005 17:36:11 +0000
(17:36 +0000)
SVN-Revision: 2423
openwrt/target/linux/rules.mk
patch
|
blob
|
history
diff --git
a/openwrt/target/linux/rules.mk
b/openwrt/target/linux/rules.mk
index 01987aaf177ba852d564f1ed7f8671a5fb9a1b2a..ec906fe1867647c2e60f8ab2989deccbc2e0c170 100644
(file)
--- a/
openwrt/target/linux/rules.mk
+++ b/
openwrt/target/linux/rules.mk
@@
-21,10
+21,10
@@
endif
$$(PKG_$(1)): $(LINUX_DIR)/.modules_done
rm -rf $$(I_$(1))
- mkdir -p $$(I_$(1))/lib/modules/$(LINUX_VERSION)
$(SCRIPT_DIR)/make-ipkg-dir.sh $$(I_$(1)) ../control/kmod-$(2).control $(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE) $(ARCH)
echo "Depends: $$(IDEPEND_$(1))" >> $$(I_$(1))/CONTROL/control
ifneq ($(strip $(3)),)
+ mkdir -p $$(I_$(1))/lib/modules/$(LINUX_VERSION)
cp $(3) $$(I_$(1))/lib/modules/$(LINUX_VERSION)
endif
ifneq ($(6),)