utils/gpsd: remove hotplug script
authorp-wassi <p.wassi@gmx.at>
Wed, 7 Dec 2016 21:00:50 +0000 (22:00 +0100)
committerJo-Philipp Wich <jo@mein.io>
Sun, 5 Feb 2017 18:42:53 +0000 (19:42 +0100)
Remove a hotplug script, which starts/stops gpsd with
attaching/detaching a PL2302 USB-UART device.

Signed-off-by: Paul Wassi <p.wassi@gmx.at>
utils/gpsd/Makefile
utils/gpsd/files/gpsd.hotplug [deleted file]

index f57ecdc5140b344a38d73aa6f923f97ae56029ec..ee72b95083fb85ee0a5797f7f114b3dad486b8d8 100644 (file)
@@ -122,8 +122,6 @@ define Package/gpsd/install
        $(INSTALL_CONF) ./files/gpsd.config $(1)/etc/config/gpsd
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/gpsd.init $(1)/etc/init.d/gpsd
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/usb
-       $(INSTALL_DATA) ./files/gpsd.hotplug $(1)/etc/hotplug.d/usb/20-gpsd
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/gpsd $(1)/usr/sbin/
 endef
diff --git a/utils/gpsd/files/gpsd.hotplug b/utils/gpsd/files/gpsd.hotplug
deleted file mode 100644 (file)
index fc15dda..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-case "$ACTION" in
-    add)
-        # start process
-        # only pl2303 devices are handled
-        if [ "$PRODUCT" = "67b/2303/300" ] && [ "$TYPE" = "0/0/0" ] && [ "$INTERFACE" = "255/0/0" ]; then
-            sleep 3 && /etc/init.d/gpsd start
-        fi
-        ;;
-    remove)
-        # stop process
-        # only pl2303 devices are handled
-        if [ "$PRODUCT" = "67b/2303/300" ] && [ "$TYPE" = "0/0/0" ] && [ "$INTERFACE" = "255/0/0" ]; then
-            /etc/init.d/gpsd stop
-        fi
-        ;;
-esac