nginx: fix rtmp module with openssl 1.1.1
authorEneas U de Queiroz <cote2004-github@yahoo.com>
Thu, 6 Dec 2018 18:39:14 +0000 (16:39 -0200)
committerEneas U de Queiroz <cote2004-github@yahoo.com>
Thu, 6 Dec 2018 18:43:14 +0000 (16:43 -0200)
Patch that changes the order of some include files in ngx_rtp_cenc.c
that caused a compilation failure.  Patch submitted upstream (#13).

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
net/nginx/Makefile
net/nginx/patches-nginx-rtmp/100-ngx_rtp_cenc.c-move-ngx_-config-core-.h-to-top.patch [new file with mode: 0644]

index bb016d031dc2c6d9e8df774deeece616c22e185e..ce9b521e5a36d62d27e1cee8173c7213662f578b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nginx
 PKG_VERSION:=1.15.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://nginx.org/download/
@@ -444,6 +444,7 @@ ifeq ($(CONFIG_NGINX_RTMP_MODULE),y)
   define  Prepare/nginx-rtmp
        $(eval $(Download/nginx-rtmp))
        gzip -dc $(DL_DIR)/$(FILE) | tar -C $(PKG_BUILD_DIR) $(TAR_OPTIONS)
+       $(call PatchDir,$(PKG_BUILD_DIR)/nginx-rtmp,./patches-nginx-rtmp)
   endef
 endif
 
diff --git a/net/nginx/patches-nginx-rtmp/100-ngx_rtp_cenc.c-move-ngx_-config-core-.h-to-top.patch b/net/nginx/patches-nginx-rtmp/100-ngx_rtp_cenc.c-move-ngx_-config-core-.h-to-top.patch
new file mode 100644 (file)
index 0000000..494d9be
--- /dev/null
@@ -0,0 +1,26 @@
+From df4113fb4d9177c7cfb0639b5e92b1fadfd4c174 Mon Sep 17 00:00:00 2001
+From: Eneas U de Queiroz <cote2004-github@yahoo.com>
+Date: Thu, 6 Dec 2018 15:54:23 -0200
+Subject: [PATCH] ngx_rtp_cenc.c: move ngx_{config,core}.h to top
+
+Fixes compilation error: unknown type name 'cpu_set_t'
+
+Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
+
+diff --git a/dash/ngx_rtmp_cenc.c b/dash/ngx_rtmp_cenc.c
+index f0b81e7..e4af2b1 100644
+--- a/dash/ngx_rtmp_cenc.c
++++ b/dash/ngx_rtmp_cenc.c
+@@ -1,10 +1,10 @@
++#include <ngx_config.h>
++#include <ngx_core.h>
+ #include <openssl/aes.h>
+ #include <openssl/rand.h>
+ #include <openssl/evp.h>
+-#include <ngx_config.h>
+-#include <ngx_core.h>
+ #include <ngx_rtmp.h>
+ #include "ngx_rtmp_cenc.h"