bird2: Prevent unaligned access on ARM
authorToke Høiland-Jørgensen <toke@toke.dk>
Fri, 6 Dec 2024 09:39:42 +0000 (10:39 +0100)
committerToke Høiland-Jørgensen <toke@toke.dk>
Fri, 6 Dec 2024 10:08:54 +0000 (11:08 +0100)
Import patch from Freifunk to enable -mno-unaligned-access - see
upstream bug report:

http://trubka.network.cz/pipermail/bird-users/2024-December/017944.html

Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk>
bird2/Makefile

index 26a3ee5e158b7b79f8c7bc09f6b8dfbc033886b0..9c672c5b9ee2634f8fa1faf0842fb24503050f2a 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bird2
 PKG_VERSION:=2.15.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=bird-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://bird.network.cz/pub/bird
@@ -97,6 +97,10 @@ protocols, telling BIRD to show various information, telling it to show
 a routing table filtered by a filter, or asking BIRD to reconfigure.
 endef
 
+ifeq ($(ARCH),arm)
+TARGET_CFLAGS+=-mno-unaligned-access
+endif
+
 CONFIGURE_ARGS += --disable-libssh
 
 define Package/bird2/conffiles