added libXcomposite
authorMirko Vogt <mirko@openwrt.org>
Mon, 22 Dec 2008 00:49:35 +0000 (00:49 +0000)
committerMirko Vogt <mirko@openwrt.org>
Mon, 22 Dec 2008 00:49:35 +0000 (00:49 +0000)
SVN-Revision: 13713

Xorg/xorg/lib/libXcomposite/Makefile [new file with mode: 0644]

diff --git a/Xorg/xorg/lib/libXcomposite/Makefile b/Xorg/xorg/lib/libXcomposite/Makefile
new file mode 100644 (file)
index 0000000..7f42f1a
--- /dev/null
@@ -0,0 +1,54 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libXcomposite
+PKG_RELEASE:=1
+PKG_VERSION:=0.4.0
+
+PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.4/src/lib/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/$(PKG_NAME)-$(PKG_VERSION)/
+PKG_MD5SUM:=7e95395dea89be21bae929b9b7f16641
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+PKG_BUILD_DEPENDS:=compositeproto fixesproto
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libXcomposite
+  SECTION:=xorg-lib
+  CATEGORY:=Xorg
+  SUBMENU:=lib
+  DEPENDS:=+libX11 +libXfixes +libXext
+  TITLE:=libXcomposite
+  URL:=http://xorg.freedesktop.org/
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/{lib/pkgconfig,include/X11/extensions}
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} \
+               $(1)/usr/lib/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
+               $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/X11/extensions/* \
+               $(1)/usr/include/X11/extensions/
+endef
+
+define Package/libXcomposite/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.so* \
+               $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libXcomposite))