uwsgi-cgi: set socket to 666 permission
authorAnsuel Smith <ansuelsmth@gmail.com>
Tue, 17 Jul 2018 23:52:09 +0000 (01:52 +0200)
committerAnsuel Smith <ansuelsmth@gmail.com>
Tue, 17 Jul 2018 23:52:09 +0000 (01:52 +0200)
Currently the socket file for uwsgi can be open only from root user, change this to permit other use to use it. (Needed for nginx to use uwsgi as nobody or dedicated user)

Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
net/uwsgi-cgi/Makefile
net/uwsgi-cgi/files-luci-support/uwsgi.conf

index ec4c0f4744ed5690264e710d41ef799a9a6cd68d..684cb6c01c286c6780842357ebc00795d51fc4ad 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uwsgi-cgi
 PKG_VERSION:=2.0.17.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL=https://codeload.github.com/unbit/uwsgi/tar.gz/$(PKG_VERSION)?
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index 82cbbb1d32bde509ad176a2af4beb7f3617370ff..7e8b2e56c880cc65a103c2fa1cf451e00c73274c 100644 (file)
@@ -24,3 +24,4 @@ pidfile               = /var/run/uwsgi.pid
 die-on-term    = true
 threads                = 3
 processes      = 3
+chmod-socket   = 666