mwan3: make mwan3.user executable
authorFlorian Eckert <fe@dev.tdt.de>
Mon, 19 Dec 2022 07:13:08 +0000 (08:13 +0100)
committerFlorian Eckert <fe@dev.tdt.de>
Mon, 19 Dec 2022 07:34:54 +0000 (08:34 +0100)
This is a fix for the the following change:
https://github.com/openwrt/packages/commit/3d824ea288d907a31729c3629e884ea122c30da0

Before the change, it was only possible to execute a shell script. To
remove this restriction, a binary or other script language can now also
be used for 'mwan3.user'. Unfortunately, the old shell script was not
executable for older mwan3 version. During a sysupgrade with config transfer,
this 'mwan3.user' script could not be executed for newer mwan3 versions.
To fix this, the calling script checks whether the 'mwan3.user' is executable,
and if not, this executable bit is now set.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
net/mwan3/Makefile
net/mwan3/files/etc/hotplug.d/iface/16-mwan3-user

index 878c4b9936e122faaeebb1299b2ddbba4da3cf1b..a72289fc680f75ebe07910f45f71ec5972f552c2 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mwan3
-PKG_VERSION:=2.11.3
-PKG_RELEASE:=3
+PKG_VERSION:=2.11.4
+PKG_RELEASE:=1
 PKG_MAINTAINER:=Florian Eckert <fe@dev.tdt.de>, \
                Aaron Goodman <aaronjg@alumni.stanford.edu>
 PKG_LICENSE:=GPL-2.0
index a9f42168b84024199ec9060398aceb5b4eb6c4eb..0960a2628784b597a1e2eefc5157eb3d5fa44adb 100644 (file)
@@ -19,6 +19,7 @@
                exit 0
        }
 
+       [ -x /etc/mwan3.user ] || chmod 755 /etc/mwan3.user
        env -i ACTION="$ACTION" INTERFACE="$INTERFACE" DEVICE="$DEVICE" /etc/mwan3.user
 }