ntpd -Split ntpdate off of ntpd's init-script, ntpd works properly without it -Make...
authorAndy Boyett <agb@openwrt.org>
Tue, 22 Apr 2008 23:33:19 +0000 (23:33 +0000)
committerAndy Boyett <agb@openwrt.org>
Tue, 22 Apr 2008 23:33:19 +0000 (23:33 +0000)
SVN-Revision: 10920

net/ntpd/Makefile
net/ntpd/files/ntpd.init
net/ntpd/files/ntpdate.init [new file with mode: 0644]

index 910d12f5d8f820b6dff2279b9c4c988a50b6921d..3d155bafae9ac2938d247749ab0cbf2bd44a1ee7 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ntp
 PKG_VERSION:=4.2.4p4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/
index c966aab63ce6d623042465dc48feee91780ed6bc..d287226cc0d08331f556446d381ced33d514dbcb 100644 (file)
@@ -1,19 +1,14 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 
-START=60
+START=65
 
-STEP_SERVERS="0.openwrt.pool.ntp.org 1.openwrt.pool.ntp.org 2.openwrt.pool.ntp.org"
 PIDFILE="/var/run/ntpd.pid"
-TIMEOUT="2" # in seconds
 
 start() {
 #      ln -sf /dev/ttyS0 /dev/gps0
 #      /usr/sbin/setgarmin -d /dev/gps -c /etc/setgarmin.conf
        stop
-       for s in $STEP_SERVERS ; do
-               /usr/sbin/ntpdate -s -b -u -t "$TIMEOUT" "$s" && break
-       done
        /usr/sbin/ntpd -g -p $PIDFILE
 }
 
diff --git a/net/ntpd/files/ntpdate.init b/net/ntpd/files/ntpdate.init
new file mode 100644 (file)
index 0000000..2f33210
--- /dev/null
@@ -0,0 +1,13 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2006-2008 OpenWrt.org
+
+START=60
+
+STEP_SERVERS="0.openwrt.pool.ntp.org 1.openwrt.pool.ntp.org 2.openwrt.pool.ntp.org"
+TIMEOUT="2" # in seconds
+
+start() {
+       for s in $STEP_SERVERS ; do
+               /usr/sbin/ntpdate -s -b -u -t "$TIMEOUT" "$s" && break
+       done
+}