php8: update to 8.0.24
authorMichael Heimpold <mhei@heimpold.de>
Tue, 4 Oct 2022 05:45:10 +0000 (07:45 +0200)
committerMichael Heimpold <mhei@heimpold.de>
Tue, 4 Oct 2022 10:33:48 +0000 (12:33 +0200)
This fixes:
    - CVE-2022-31629
    - CVE-2022-31628

Also refresh patch to apply cleanly.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lang/php8/Makefile
lang/php8/patches/0041-Add-patch-to-remove-build-timestamps-from-generated-.patch

index a472949bec4f9df0f4c67cc880483e345fc2a1a7..534cbce13952eb5c6ba3a737161f8597381f592e 100644 (file)
@@ -6,7 +6,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
-PKG_VERSION:=8.0.20
+PKG_VERSION:=8.0.24
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
@@ -16,7 +16,7 @@ PKG_CPE_ID:=cpe:/a:php:php
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://www.php.net/distributions/
-PKG_HASH:=973fec765336ee01f47536a5db1c2eee98df9d34a41522b7b6c760159bf0a77b
+PKG_HASH:=8e6a63ac9cdabe4c345b32a54b18f348d9e50a1decda217faf2d61278d22f08b
 
 PKG_BUILD_PARALLEL:=1
 PKG_USE_MIPS16:=0
index 39275c165b45f6589ec7a4b53c647706c04dc70f..6b2ed167a977dcd46d17ccf961421a49d809cf34 100644 (file)
@@ -54,7 +54,7 @@ Subject: Add patch to remove build timestamps from generated binaries.
                                                        fcgi_shutdown();
 --- a/sapi/cli/php_cli.c
 +++ b/sapi/cli/php_cli.c
-@@ -635,8 +635,8 @@ static int do_cli(int argc, char **argv)
+@@ -633,8 +633,8 @@ static int do_cli(int argc, char **argv)
                                goto out;
  
                        case 'v': /* show php version & quit */