simple-adblock: use new extra_command function definition
authorFlorian Eckert <fe@dev.tdt.de>
Wed, 28 Oct 2020 14:56:21 +0000 (15:56 +0100)
committerFlorian Eckert <fe@dev.tdt.de>
Wed, 4 Nov 2020 07:50:34 +0000 (08:50 +0100)
Signed-off-by: Florian Eckert <fe@dev.tdt.de>
net/simple-adblock/Makefile
net/simple-adblock/files/simple-adblock.init

index 35a9f0f25f94d7f081a467f050904c842100eab2..aaa9753b4aef09f6ed4d19df6f6c29e8de3e310a 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=simple-adblock
 PKG_VERSION:=1.8.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
 PKG_LICENSE:=GPL-3.0-or-later
 
index ba2a597e84debdc4f548687f4432cca8bc6cd950..0c04998ec3d1ada81824badf0b0c71e3f76b3481 100644 (file)
@@ -10,12 +10,11 @@ USE_PROCD=1
 LC_ALL=C
 
 # shellcheck disable=SC2034
-EXTRA_COMMANDS='check dl killcache sizes show version'
-# shellcheck disable=SC2034
-EXTRA_HELP='   check   Checks if specified domain is found in current block-list
-       dl      Force-downloads all enabled block-list
-       sizes   Displays the file-sizes of enabled block-lists
-       show    Shows the service last-run status'
+extra_command "check" "Checks if specified domain is found in current block-list"
+extra_command "dl" "Force-downloads all enabled block-list"
+extra_command "sizes" "Displays the file-sizes of enabled block-listo"
+extra_command "show" "Shows the service last-run status"
+extra_command "version" "Show version"
 
 readonly packageName='simple-adblock'
 readonly serviceName="$packageName $PKG_VERSION"