projects
/
feed
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
af5585a
)
cgi-io: cmake: fix libraries lookup
author
Petr Štetiar
<ynezz@true.cz>
Fri, 11 Oct 2019 13:01:42 +0000
(15:01 +0200)
committer
Petr Štetiar
<ynezz@true.cz>
Fri, 11 Oct 2019 14:13:11 +0000
(16:13 +0200)
In order to make it compile properly in more environments.
Signed-off-by: Petr Štetiar <ynezz@true.cz>
(cherry picked from commit
fd47e99be4fcd9b1261a4f359279d63199fff6c3
)
net/cgi-io/src/CMakeLists.txt
patch
|
blob
|
history
diff --git
a/net/cgi-io/src/CMakeLists.txt
b/net/cgi-io/src/CMakeLists.txt
index 6d8b1585a8b2a26c04839b5679038a9e96f59819..56d9fa7f1601f32589e6c98f5fac631573b0eb23 100644
(file)
--- a/
net/cgi-io/src/CMakeLists.txt
+++ b/
net/cgi-io/src/CMakeLists.txt
@@
-5,6
+5,8
@@
PROJECT(cgi-io C)
INCLUDE(CheckFunctionExists)
FIND_PATH(ubus_include_dir libubus.h)
+FIND_LIBRARY(ubox NAMES ubox)
+FIND_LIBRARY(ubus NAMES ubus)
INCLUDE_DIRECTORIES(${ubus_include_dir})
ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations)
@@
-17,6
+19,6
@@
IF(APPLE)
ENDIF()
ADD_EXECUTABLE(cgi-io main.c multipart_parser.c)
-TARGET_LINK_LIBRARIES(cgi-io
ubox ubus
)
+TARGET_LINK_LIBRARIES(cgi-io
${ubox} ${ubus}
)
INSTALL(TARGETS cgi-io RUNTIME DESTINATION sbin)