davfs2: fix compilation with GCC10
authorRosen Penev <rosenp@gmail.com>
Thu, 2 Jul 2020 22:29:24 +0000 (15:29 -0700)
committerRosen Penev <rosenp@gmail.com>
Fri, 3 Jul 2020 02:17:50 +0000 (19:17 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/davfs2/Makefile
net/davfs2/patches/400-gcc10.patch [new file with mode: 0644]

index 0fc2580e06cf950702445eec242ef5b7799048f5..32deede9cdd553d6f6768df886af9e93d15b5f2d 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=davfs2
 PKG_VERSION:=1.5.5
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SAVANNAH/davfs2
diff --git a/net/davfs2/patches/400-gcc10.patch b/net/davfs2/patches/400-gcc10.patch
new file mode 100644 (file)
index 0000000..046c67e
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/dav_coda.c
++++ b/src/dav_coda.c
+@@ -97,7 +97,7 @@ static unsigned int blocksize;
+ static size_t alignment;
+ /* Send debug messages to syslog if != 0. */
+-int debug;
++extern int debug;
+ /* Private function prototypes */