ramips: make package kmod-sdhci-mt7620 conflict with kmod-mmc-mtk
authorShiji Yang <yangshiji66@qq.com>
Wed, 1 Jan 2025 08:17:08 +0000 (16:17 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 4 Jan 2025 13:47:53 +0000 (14:47 +0100)
These two packages are SDXC drivers for Mediatek mt762x series SoCs.
One is upstream implementation, and the other is downstream driver.
Installing them together will result in conflicts.

Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Link: https://github.com/openwrt/openwrt/pull/17446
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/ramips/modules.mk

index ced479dc93e9cb76890005491977f4dcb04d8ddd..175ba94eff988bedf1761ce9a71a0a049814eb7f 100644 (file)
@@ -47,6 +47,7 @@ $(eval $(call KernelPackage,pwm-mediatek-ramips))
 define KernelPackage/sdhci-mt7620
   SUBMENU:=Other modules
   TITLE:=MT7620 SDCI
+  CONFLICTS:=kmod-mmc-mtk
   DEPENDS:=@(TARGET_ramips_mt7620||TARGET_ramips_mt76x8||TARGET_ramips_mt7621) +kmod-mmc
   KCONFIG:= \
        CONFIG_MTK_MMC \