postgresql: security update to 13.7
authorMichal Vasilek <michal.vasilek@nic.cz>
Fri, 13 May 2022 16:39:54 +0000 (18:39 +0200)
committerRosen Penev <rosenp@gmail.com>
Sun, 15 May 2022 04:34:19 +0000 (21:34 -0700)
* fixes CVE-2022-1552
* refresh a patch

Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
libs/postgresql/Makefile
libs/postgresql/patches/900-pg_ctl-setuid.patch

index fbb9fdbb1709648b978612867e28199ee4bb9235..512af13965e42db181aef62c3b451d0983092b6d 100644 (file)
@@ -5,7 +5,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
-PKG_VERSION:=13.5
+PKG_VERSION:=13.7
 PKG_RELEASE:=1
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 PKG_LICENSE:=PostgreSQL
@@ -17,7 +17,7 @@ PKG_SOURCE_URL:=\
        http://ftp.postgresql.org/pub/source/v$(PKG_VERSION) \
        ftp://ftp.postgresql.org/pub/source/v$(PKG_VERSION)
 
-PKG_HASH:=9b81067a55edbaabc418aacef457dd8477642827499560b00615a6ea6c13f6b3
+PKG_HASH:=1b905bf4f3d83614a393b3c51fd345910fd261e4f5124a68d9a1fdd3a2a46399
 
 PKG_USE_MIPS16:=0
 PKG_FIXUP:=autoreconf
index 8203fbf1dbda8e662655c75966af948ae1066d75..b9e3de2c1309e3607514c0732c8a1c4a93073198 100644 (file)
@@ -8,7 +8,7 @@
  static char *argv0 = NULL;
  static bool allow_core_files = false;
  static time_t start_time;
-@@ -2055,6 +2056,9 @@ do_help(void)
+@@ -2087,6 +2088,9 @@ do_help(void)
  #endif
        printf(_("  -s, --silent           only print errors, no informational messages\n"));
        printf(_("  -t, --timeout=SECS     seconds to wait when using -w option\n"));
@@ -18,7 +18,7 @@
        printf(_("  -V, --version          output version information, then exit\n"));
        printf(_("  -w, --wait             wait until operation completes (default)\n"));
        printf(_("  -W, --no-wait          do not wait until operation completes\n"));
-@@ -2267,6 +2271,7 @@ main(int argc, char **argv)
+@@ -2299,6 +2303,7 @@ main(int argc, char **argv)
                {"options", required_argument, NULL, 'o'},
                {"silent", no_argument, NULL, 's'},
                {"timeout", required_argument, NULL, 't'},
@@ -26,7 +26,7 @@
                {"core-files", no_argument, NULL, 'c'},
                {"wait", no_argument, NULL, 'w'},
                {"no-wait", no_argument, NULL, 'W'},
-@@ -2307,20 +2312,6 @@ main(int argc, char **argv)
+@@ -2339,20 +2344,6 @@ main(int argc, char **argv)
                }
        }
  
@@ -47,7 +47,7 @@
  
        env_wait = getenv("PGCTLTIMEOUT");
        if (env_wait != NULL)
-@@ -2407,11 +2398,15 @@ main(int argc, char **argv)
+@@ -2439,11 +2430,15 @@ main(int argc, char **argv)
                                        wait_seconds_arg = true;
                                        break;
                                case 'U':
@@ -63,7 +63,7 @@
                                        break;
                                case 'w':
                                        do_wait = true;
-@@ -2493,6 +2488,41 @@ main(int argc, char **argv)
+@@ -2525,6 +2520,41 @@ main(int argc, char **argv)
                exit(1);
        }