golang: Fix handling of filenames with spaces
authorJeffery To <jeffery.to@gmail.com>
Sat, 9 Feb 2019 11:42:06 +0000 (19:42 +0800)
committerJeffery To <jeffery.to@gmail.com>
Mon, 11 Feb 2019 12:33:44 +0000 (20:33 +0800)
Closes #7127.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/golang/golang-package.mk

index 1df4c3fec53dbcf9e1d0377a259f5430aa60b966..4551d7b70dcda2ace6280d26ef6ffa16a791c4d3 100644 (file)
@@ -164,6 +164,8 @@ define GoPackage/Build/Configure
                        files=$$$$(echo "$$$$files" | grep -v '^[[:space:]]*$$$$' | sort -u) ; \
                fi ; \
                \
+               IFS=$$$$'\n' ; \
+               \
                echo "Copying files from $(PKG_BUILD_DIR) into $(GO_PKG_BUILD_DIR)/src/$(GO_PKG)" ; \
                for file in $$$$files; do \
                        echo $$$$file ; \