libiio: update to 0.21
authorMichael Heimpold <mhei@heimpold.de>
Thu, 10 Sep 2020 19:40:12 +0000 (21:40 +0200)
committerMichael Heimpold <mhei@heimpold.de>
Thu, 10 Sep 2020 19:40:12 +0000 (21:40 +0200)
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
libs/libiio/Makefile
libs/libiio/patches/0001-Update-channel-type-and-modifier-lists.patch [deleted file]

index 09259be7080ec79dd5abb565bd48c0e136f381d3..98288ccb807e11100ba118bed32b18a0d793c9b2 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiio
-PKG_VERSION:=0.19
+PKG_VERSION:=0.21
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/analogdevicesinc/libiio/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=81c414d5c47b715d9bc9275b9fabbfd9e9483e60c035f3001b5977932049595d
+PKG_HASH:=03d13165cbeb83b036743cbd9a10e336c728da162714f39d13250a3d94305cac
 
 PKG_LICENSE:=LGPL-2.1
 PKG_LICENSE_FILES:=COPYING.txt
diff --git a/libs/libiio/patches/0001-Update-channel-type-and-modifier-lists.patch b/libs/libiio/patches/0001-Update-channel-type-and-modifier-lists.patch
deleted file mode 100644 (file)
index 96630be..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-From 98ba73179f6db323b68a8d59e90c2d7c39a16736 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
-Date: Tue, 3 Mar 2020 18:27:42 +0100
-Subject: [PATCH] Update channel type and modifier lists
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Update the channel type and modifier lists against Linux 5.4.22.
-
-Signed-off-by: Petr Štetiar <ynezz@true.cz>
----
- channel.c | 10 ++++++++++
- iio.h     | 10 ++++++++++
- 2 files changed, 20 insertions(+)
-
-diff --git a/channel.c b/channel.c
-index 302592dfc764..407ce632fcc7 100644
---- a/channel.c
-+++ b/channel.c
-@@ -56,6 +56,9 @@ static const char * const iio_chan_type_name_spec[] = {
-       [IIO_COUNT] = "count",
-       [IIO_INDEX] = "index",
-       [IIO_GRAVITY] = "gravity",
-+      [IIO_POSITIONRELATIVE] = "positionrelative",
-+      [IIO_PHASE] = "phase",
-+      [IIO_MASSCONCENTRATION] = "massconcentration",
- };
- static const char * const modifier_names[] = {
-@@ -79,6 +82,7 @@ static const char * const modifier_names[] = {
-       [IIO_MOD_LIGHT_GREEN] = "green",
-       [IIO_MOD_LIGHT_BLUE] = "blue",
-       [IIO_MOD_LIGHT_UV] = "uv",
-+      [IIO_MOD_LIGHT_DUV] = "duv",
-       [IIO_MOD_QUATERNION] = "quaternion",
-       [IIO_MOD_TEMP_AMBIENT] = "ambient",
-       [IIO_MOD_TEMP_OBJECT] = "object",
-@@ -94,7 +98,13 @@ static const char * const modifier_names[] = {
-       [IIO_MOD_I] = "i",
-       [IIO_MOD_Q] = "q",
-       [IIO_MOD_CO2] = "co2",
-+      [IIO_MOD_ETHANOL] = "ethanol",
-+      [IIO_MOD_H2] = "h2",
-       [IIO_MOD_VOC] = "voc",
-+      [IIO_MOD_PM1] = "pm1",
-+      [IIO_MOD_PM2P5] = "pm2p5",
-+      [IIO_MOD_PM4] = "pm4",
-+      [IIO_MOD_PM10] = "pm10",
- };
- /*
-diff --git a/iio.h b/iio.h
-index 5c11fcefe5c2..5afc28ea0197 100644
---- a/iio.h
-+++ b/iio.h
-@@ -125,6 +125,9 @@ enum iio_chan_type {
-       IIO_COUNT,
-       IIO_INDEX,
-       IIO_GRAVITY,
-+      IIO_POSITIONRELATIVE,
-+      IIO_PHASE,
-+      IIO_MASSCONCENTRATION,
-       IIO_CHAN_TYPE_UNKNOWN = INT_MAX
- };
-@@ -173,6 +176,13 @@ enum iio_modifier {
-       IIO_MOD_CO2,
-       IIO_MOD_VOC,
-       IIO_MOD_LIGHT_UV,
-+      IIO_MOD_LIGHT_DUV,
-+      IIO_MOD_PM1,
-+      IIO_MOD_PM2P5,
-+      IIO_MOD_PM4,
-+      IIO_MOD_PM10,
-+      IIO_MOD_ETHANOL,
-+      IIO_MOD_H2,
- };
- /* ---------------------------------------------------------------------------*/