python: enforce the existence of files in the filespecs
authorAlexandru Ardelean <aa@ocedo.com>
Thu, 16 Oct 2014 13:15:56 +0000 (16:15 +0300)
committerAlexandru Ardelean <aa@ocedo.com>
Fri, 17 Oct 2014 13:30:45 +0000 (16:30 +0300)
Seems that this allows some goofs, because some files
silently do not get copied and the build succeeds, even though
it shouldn't.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/files/python-package.mk

index 6ac6051fa64c1ea6ecc457c5f66ba5b386f38afa..dc30494feec690e4fb252cdba490b5f6ca892cff 100644 (file)
@@ -37,6 +37,10 @@ define PyPackage
                IFS='|'; \
                while read fop fspec fperm; do \
                  if [ "$$$$$$$$fop" = "+" ]; then \
+                       if [ ! -e "$(PKG_INSTALL_DIR)$$$$$$$$fspec" ]; then \
+                         echo "File not found '$(PKG_INSTALL_DIR)$$$$$$$$fspec'"; \
+                         exit 1; \
+                       fi; \
                        dpath=`dirname "$$$$$$$$fspec"`; \
                        if [ -n "$$$$$$$$fperm" ]; then \
                          dperm="-m$$$$$$$$fperm"; \