luci-app-pbr: sync with principal package
authorStan Grishin <stangri@melmac.ca>
Tue, 3 Sep 2024 20:25:16 +0000 (20:25 +0000)
committerStan Grishin <stangri@melmac.ca>
Tue, 3 Sep 2024 20:25:16 +0000 (20:25 +0000)
Signed-off-by: Stan Grishin <stangri@melmac.ca>
applications/luci-app-pbr/Makefile
applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js
applications/luci-app-pbr/po/templates/pbr.pot
applications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr

index 591e4e323bbb5f805349c317fd009ee7f9d6e771..d6739a914dc127d33356d3777b40cd8e3e7eb4b8 100644 (file)
@@ -6,8 +6,8 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=luci-app-pbr
 PKG_LICENSE:=AGPL-3.0-or-later
 PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
-PKG_VERSION:=1.1.6
-PKG_RELEASE:=20
+PKG_VERSION:=1.1.7
+PKG_RELEASE:=7
 
 LUCI_TITLE:=Policy Based Routing Service Web UI
 LUCI_URL:=https://github.com/stangri/luci-app-pbr/
@@ -24,6 +24,6 @@ help
        Version: $(PKG_VERSION)-$(PKG_RELEASE)
 endef
 
-include ../../luci.mk
+include $(TOPDIR)/feeds/luci/luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 184e1285b1f06e4f42be444797aecd96de18d6c4..1afbf6d35eff4fbfa70bb3cdeed81c51c044d142 100644 (file)
@@ -11,7 +11,7 @@ var pkg = {
                return "pbr";
        },
        get ReadmeCompat() {
-               return "1.1.6-16";
+               return "1.1.7-1";
        },
        get URL() {
                return (
@@ -383,16 +383,19 @@ var status = baseclass.extend({
                                        ),
                                        errorNftFileInstall: _("Failed to install fw4 nft file '%s'"),
                                        errorNoDownloadWithSecureReload: _(
-                                               "Policy '%s' refers to URL which can't be downloaded in 'secure_reload' mode!"
+                                               "Policy '%s' refers to URL which can't be downloaded in 'secure_reload' mode"
                                        ),
                                        errorDownloadUrlNoHttps: _(
-                                               "Failed to download '%s', HTTPS is not supported!"
+                                               "Failed to download '%s', HTTPS is not supported"
                                        ),
-                                       errorDownloadUrl: _("Failed to download '%s'!"),
+                                       errorDownloadUrl: _("Failed to download '%s'"),
                                        errorFileSchemaRequiresCurl: _(
-                                               "The file:// schema requires curl, but it's not detected on this system!"
+                                               "The file:// schema requires curl, but it's not detected on this system"
+                                       ),
+                                       errorTryFailed: _("Command failed: '%s'"),
+                                       errorIncompatibleUserFile: _(
+                                               "Incompatible custom user file detected '%s'"
                                        ),
-                                       errorTryFailed: _("Command failed: %s"),
                                };
                                var errorsTitle = E(
                                        "label",
index 3d3323625be97170603cb1c0de6b48c828da942d..cc0abc0d7f2a9bff4b31337eacb954ece1df4be3 100644 (file)
@@ -67,7 +67,7 @@ msgid "Chain"
 msgstr ""
 
 #: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:395
-msgid "Command failed: %s"
+msgid "Command failed: '%s'"
 msgstr ""
 
 #: applications/luci-app-pbr/htdocs/luci-static/resources/view/pbr/overview.js:71
@@ -106,7 +106,7 @@ msgstr ""
 msgid "Default ICMP Interface"
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:526
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:529
 msgid "Disable"
 msgstr ""
 
@@ -116,7 +116,7 @@ msgstr ""
 msgid "Disabled"
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:520
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:523
 msgid "Disabling %s service"
 msgstr ""
 
@@ -142,11 +142,11 @@ msgstr ""
 msgid "Do not enforce policies when their gateway is down"
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:573
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:576
 msgid "Donate to the Project"
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:507
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:510
 msgid "Enable"
 msgstr ""
 
@@ -158,7 +158,7 @@ msgstr ""
 msgid "Enabled"
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:501
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:504
 msgid "Enabling %s service"
 msgstr ""
 
@@ -166,7 +166,7 @@ msgstr ""
 msgid "Error running custom user file '%s'"
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:415
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:418
 msgid "Errors encountered, please check the %sREADME%s"
 msgstr ""
 
@@ -177,11 +177,11 @@ msgid ""
 msgstr ""
 
 #: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:391
-msgid "Failed to download '%s'!"
+msgid "Failed to download '%s'"
 msgstr ""
 
 #: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:389
-msgid "Failed to download '%s', HTTPS is not supported!"
+msgid "Failed to download '%s', HTTPS is not supported"
 msgstr ""
 
 #: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:384
@@ -228,6 +228,10 @@ msgstr ""
 msgid "Inactive (Disabled)"
 msgstr ""
 
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:397
+msgid "Incompatible custom user file detected '%s'"
+msgstr ""
+
 #: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:263
 msgid ""
 "Incompatible nft calls detected in user include file, disabling fw4 nft file "
@@ -321,7 +325,7 @@ msgid "Path"
 msgstr ""
 
 #: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:215
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:581
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:584
 msgid "Please %sdonate%s to support development of this project."
 msgstr ""
 
@@ -367,7 +371,7 @@ msgstr ""
 
 #: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:386
 msgid ""
-"Policy '%s' refers to URL which can't be downloaded in 'secure_reload' mode!"
+"Policy '%s' refers to URL which can't be downloaded in 'secure_reload' mode"
 msgstr ""
 
 #: applications/luci-app-pbr/htdocs/luci-static/resources/view/status/include/72_pbr.js:10
@@ -432,11 +436,11 @@ msgid ""
 "Resolver set support (%s) requires nftables, but nft binary cannot be found"
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:469
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:472
 msgid "Restart"
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:463
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:466
 msgid "Restarting %s service"
 msgstr ""
 
@@ -462,11 +466,11 @@ msgstr ""
 msgid "Select Add for -A/add and Insert for -I/Insert."
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:552
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:555
 msgid "Service Control"
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:400
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:403
 msgid "Service Errors"
 msgstr ""
 
@@ -497,11 +501,11 @@ msgstr ""
 msgid "Skipping IPv6 policy '%s' as IPv6 support is disabled"
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:450
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:453
 msgid "Start"
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:444
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:447
 msgid "Starting %s service"
 msgstr ""
 
@@ -515,7 +519,7 @@ msgstr ""
 msgid "Status"
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:488
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:491
 msgid "Stop"
 msgstr ""
 
@@ -527,7 +531,7 @@ msgstr ""
 msgid "Stopped."
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:482
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:485
 msgid "Stopping %s service"
 msgstr ""
 
@@ -586,7 +590,7 @@ msgid "The WebUI application (luci-app-pbr) is outdated, please update it"
 msgstr ""
 
 #: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:393
-msgid "The file:// schema requires curl, but it's not detected on this system!"
+msgid "The file:// schema requires curl, but it's not detected on this system"
 msgstr ""
 
 #: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:329
@@ -605,7 +609,7 @@ msgstr ""
 msgid "Unexpected exit or service termination: '%s'"
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:412
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:415
 msgid "Unknown error!"
 msgstr ""
 
index b0316d96bee3d6016d02a1df9fa6ffa593757424..4bd154a43d7a58659b36c38af36d01ead8b28f7f 100755 (executable)
@@ -11,7 +11,7 @@
 # ubus -S call luci.pbr getGateways '{"name": "pbr" }'
 # ubus -S call luci.pbr getInterfaces '{"name": "pbr" }'
 
-readonly luciCompat='5'
+readonly luciCompat='7'
 readonly pbrFunctionsFile='/etc/init.d/pbr'
 if [ -s "$pbrFunctionsFile" ]; then
 # shellcheck source=../../../../../pbr/files/etc/init.d/pbr