libowfat: Fix compile with glibc 2.36
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 6 Nov 2022 15:42:33 +0000 (16:42 +0100)
committerRosen Penev <rosenp@gmail.com>
Sun, 6 Nov 2022 20:54:15 +0000 (12:54 -0800)
This fixes the following error message seen when compiling against
glibc 2.36:
                 from scan/scan_httpdate.c:3:
include/sys/cdefs.h:338:65: error: macro "__has_attribute" requires an identifier
  338 | #if __GNUC_PREREQ (3,2) || __glibc_has_attribute (__deprecated__)

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
libs/libowfat/Makefile
libs/libowfat/patches/012-remove-deprecated.patch [new file with mode: 0644]

index e932625094b722b82d040337c8d856a034a5f59e..9f9fc742ddf9f3596c65c8b08874a846c68f2226 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libowfat
 PKG_VERSION:=0.32
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.fefe.de/libowfat
diff --git a/libs/libowfat/patches/012-remove-deprecated.patch b/libs/libowfat/patches/012-remove-deprecated.patch
new file mode 100644 (file)
index 0000000..49e3c82
--- /dev/null
@@ -0,0 +1,16 @@
+--- a/scan/scan_iso8601.c
++++ b/scan/scan_iso8601.c
+@@ -1,5 +1,4 @@
+ #define _GNU_SOURCE
+-#define __deprecated__
+ #include "scan.h"
+ #include "byte.h"
+ #include "case.h"
+--- a/scan/scan_httpdate.c
++++ b/scan/scan_httpdate.c
+@@ -1,5 +1,4 @@
+ #define _GNU_SOURCE
+-#define __deprecated__
+ #include "scan.h"
+ #include "byte.h"
+ #include "case.h"