libmbim: fix compile on build bots
authorSebastian Kemper <sebastian_ml@gmx.net>
Mon, 28 Oct 2019 18:21:42 +0000 (19:21 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Mon, 28 Oct 2019 18:21:45 +0000 (19:21 +0100)
On the OpenWrt build bots the compile currently fails:

make[8]: Entering directory '/builder/shared-workdir/build/sdk/build_dir/target-arm_cortex-a5+vfpv4_musl_eabi/libmbim-1.20.0/src/common'
  CC       libmbim_common_la-mbim-common.lo
cc1: error: /builder/shared-workdir/build/sdk/staging_dir/target-arm_cortex-a5+vfpv4_musl_eabi/include: No such file or directory [-Werror=missing-include-dirs]
cc1: all warnings being treated as errors

The directory in question gets added to TARGET_CPPFLAGS by rules.mk.
Nothing usually gets installed to that directory, so unsurprisingly it
may not exist on the build bots.

On first glance this problem cannot be reproduced. But once autoreconf
is called this becomes possible.

If called without "--enable-more-warnings", configure adds -Werror to
the flags. This commit adds "--enable-more-warnings=yes" to the build.
This way the extra warnings are kept in place, but they aren't turned
into errors no more.

"PKG_FIXUP:=autoreconf" is also added so that it's easier to forecast
build failures on the build bots when preparing future pull request.

Last but not least "--disable-silent-rules" is added, because more
output is usually welcome for debugging, be it on the build bots or at
home/the office.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
libs/libmbim/Makefile

index 00982485d36408103e32aeee0fcfc742d8b3fafb..d60d06ffb0c61bd1320968fcd21b43334d4b5770 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libmbim
 PKG_VERSION:=1.20.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.freedesktop.org/software/libmbim
@@ -20,6 +20,8 @@ PKG_MAINTAINER:=Nicholas Smith <nicholas.smith@telcoantennas.com.au>
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 
+PKG_FIXUP:=autoreconf
+
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 
@@ -27,7 +29,9 @@ CONFIGURE_ARGS += \
        --disable-static \
        --disable-gtk-doc \
        --disable-gtk-doc-html \
-       --disable-gtk-doc-pdf
+       --disable-gtk-doc-pdf \
+       --disable-silent-rules \
+       --enable-more-warnings=yes
 
 define Package/libmbim
   SECTION:=libs