projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5625625
)
build: Check if swig is istalled
author
Hauke Mehrtens
<hauke@hauke-m.de>
Sun, 13 Feb 2022 17:22:51 +0000
(18:22 +0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sun, 13 Feb 2022 17:22:51 +0000
(18:22 +0100)
include/u-boot.mk
patch
|
blob
|
history
diff --git
a/include/u-boot.mk
b/include/u-boot.mk
index 509b3d76dc54064965a15df5356a4fbbdb6d0d5e..a3d6b4da2c470a9e9827035cc8be48725072096a 100644
(file)
--- a/
include/u-boot.mk
+++ b/
include/u-boot.mk
@@
-39,6
+39,13
@@
define U-Boot/Init
UBOOT_IMAGE:=u-boot.bin
endef
+ifdef NEEDS_SWIG
+$(eval $(call SetupHostCommand,swig,Please install 'swig', \
+ swig -python -help |grep "Python", \
+ swig))
+endif
+
+
TARGET_DEP = TARGET_$(BUILD_TARGET)$(if $(BUILD_SUBTARGET),_$(BUILD_SUBTARGET))
UBOOT_MAKE_FLAGS = \