tor: remove libssp hack
authorRosen Penev <rosenp@gmail.com>
Tue, 16 Jun 2020 22:41:19 +0000 (15:41 -0700)
committerRosen Penev <rosenp@gmail.com>
Thu, 18 Jun 2020 22:14:33 +0000 (15:14 -0700)
Does not seem to be needed anymore.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/tor/Makefile

index 0bac41a3ee0969cc51ba9e12b59aa6abc3a80248..ee6e327cfc4c9b1c56114ba766a61c99ddd0d136 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor
 PKG_VERSION:=0.4.3.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://dist.torproject.org/ \
@@ -103,18 +103,12 @@ CONFIGURE_ARGS += \
        --disable-lzma \
        --disable-zstd \
        --with-tor-user=tor \
-       --with-tor-group=tor
+       --with-tor-group=tor \
+       --with-pic
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
 TARGET_LDFLAGS += -Wl,--gc-sections -flto
 
-ifneq ($(CONFIG_SSP_SUPPORT),y)
-       CONFIGURE_ARGS += \
-               --disable-gcc-hardening
-else
-       EXTRA_CFLAGS += $(FPIC)
-endif
-
 CONFIGURE_VARS += \
        CROSS_COMPILE="yes"