squid: Fix compilation without OpenSSL ENGINE support
authorRosen Penev <rosenp@gmail.com>
Mon, 7 Jan 2019 05:02:59 +0000 (21:02 -0800)
committerRosen Penev <rosenp@gmail.com>
Mon, 7 Jan 2019 05:02:59 +0000 (21:02 -0800)
OpenSSL 1.1 includes the header but support has to be checked in another
way.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/squid/Makefile
net/squid/patches/010-openssl-engine.patch [new file with mode: 0644]

index 19c5786ab2313f978d8a678bac566622a36dc937..4433d0668eb0b686163fddd6d4bbb9985cac6e74 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=squid
 PKG_VERSION:=4.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_LICENSE:=GPL-2.0
 PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
diff --git a/net/squid/patches/010-openssl-engine.patch b/net/squid/patches/010-openssl-engine.patch
new file mode 100644 (file)
index 0000000..e7f97ee
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/ssl/support.cc
++++ b/src/ssl/support.cc
+@@ -485,7 +485,7 @@ Ssl::Initialize(void)
+     SQUID_OPENSSL_init_ssl();
+-#if HAVE_OPENSSL_ENGINE_H
++#ifndef OPENSSL_NO_ENGINE
+     if (::Config.SSL.ssl_engine) {
+         ENGINE_load_builtin_engines();
+         ENGINE *e;