samba4: update to 4.18.6
authorMichal Hrusecky <michal.hrusecky@turris.com>
Wed, 20 Sep 2023 11:22:18 +0000 (13:22 +0200)
committerRosen Penev <rosenp@gmail.com>
Sun, 24 Sep 2023 02:15:21 +0000 (19:15 -0700)
Update to the version of samba4 from 23.05 as version 4.14 is no longer
supported by upstream since 2022-09-13:

https://wiki.samba.org/index.php/Samba_Release_Planning#General_information

Signed-off-by: Michal Hrusecky <michal.hrusecky@turris.com>
28 files changed:
net/samba4/Config.in
net/samba4/Makefile
net/samba4/patches/001-samba-4.4.0-pam.patch [deleted file]
net/samba4/patches/002-dnsserver-4.7.0.patch [deleted file]
net/samba4/patches/006-netdb-defines.patch [deleted file]
net/samba4/patches/007-libldb-fix-musl-libc-unkown-type-error.patch
net/samba4/patches/009-samba-4-11-fix-host-tools-checks.patch.patch
net/samba4/patches/010-samba-4-12-fix-musl_missing__nss_buflen_passwd.patch
net/samba4/patches/011-samba-4-14-disable-python-module-host-check.patch
net/samba4/patches/020-source3-msgsock-nvram-fix.patch
net/samba4/patches/021-source4-msgsock-nvram-fix.patch
net/samba4/patches/030_wafsamba-replace-echo-n-with-printf.patch [deleted file]
net/samba4/patches/102-samba-4.11-unbundle-libbsd.patch
net/samba4/patches/103-samba-4.12-unbundle-libunwind.patch
net/samba4/patches/105-perl-json-pp.patch [new file with mode: 0644]
net/samba4/waf-cross-answers/aarch64.txt
net/samba4/waf-cross-answers/arc.txt
net/samba4/waf-cross-answers/arm.txt
net/samba4/waf-cross-answers/armeb.txt
net/samba4/waf-cross-answers/i386.txt
net/samba4/waf-cross-answers/mips.txt
net/samba4/waf-cross-answers/mips64.txt
net/samba4/waf-cross-answers/mips64el.txt
net/samba4/waf-cross-answers/mipsel.txt
net/samba4/waf-cross-answers/powerpc.txt
net/samba4/waf-cross-answers/powerpc64.txt
net/samba4/waf-cross-answers/riscv64.txt [new file with mode: 0644]
net/samba4/waf-cross-answers/x86_64.txt

index d287effa5e312dedaa14e1c181d1d66fb7f2fccb..21cbb1dc2439369b420d874f3bec631d6e4f0290 100644 (file)
@@ -31,12 +31,22 @@ config SAMBA4_SERVER_AVAHI
                Announce Samba resources via DNS/DNS-SD using the Avahi daemon, for Linux/Mac clients.
        default y
 
+config SAMBA4_SERVER_QUOTAS
+       bool "Quotas support"
+       depends on PACKAGE_samba4-server
+       select SAMBA4_SERVER_VFS
+       help
+               Enable VFS Quotas
+               installs:
+                       modules: vfs_default_quota
+       default n
+
 config SAMBA4_SERVER_VFS
        bool "Common VFS modules"
        depends on PACKAGE_samba4-server
        help
                installs:
-                       modules: (vfs_btrfs) vfs_fruit vfs_shadow_copy2 vfs_recycle vfs_fake_perms vfs_readonly vfs_cap vfs_offline vfs_crossrename vfs_catia vfs_streams_xattr vfs_default_quota
+                       modules: (vfs_btrfs) vfs_fruit vfs_shadow_copy2 vfs_recycle vfs_fake_perms vfs_readonly vfs_cap vfs_offline vfs_crossrename vfs_catia vfs_streams_xattr
 
                Commonly used VFS modules, vfs_btrfs requires kmod-fs-btrfs to be selected separately
        default y
index d80a182602bf5983934a9837693958adc8cac976..4144ee1528be9f3d10db32326367635b2e198b54 100644 (file)
@@ -2,8 +2,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
-PKG_VERSION:=4.14.14
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_VERSION:=4.18.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
@@ -13,7 +13,9 @@ PKG_SOURCE_URL:= \
                http://www.nic.funet.fi/index/samba/pub/samba/stable/ \
                http://samba.mirror.bit.nl/samba/ftp/stable/ \
                https://download.samba.org/pub/samba/stable/
-PKG_HASH:=abd5e9e6aa45e55114b188ba189ebdfc8fd3d7718d43f749e477ce7f791e5519
+PKG_HASH:=70348656ef807be9c8be4465ca157cef4d99818e234253d2c684cc18b8408149
+
+PKG_BUILD_FLAGS:=gc-sections
 
 PKG_LICENSE:=GPL-3.0-only
 PKG_LICENSE_FILES:=COPYING
@@ -21,11 +23,12 @@ PKG_CPE_ID:=cpe:/a:samba:samba
 
 # samba4=(asn1_compile,compile_et) rpcsvc-proto=(rpcgen)
 HOST_BUILD_DEPENDS:=python3/host rpcsvc-proto/host perl/host perl-parse-yapp/host
-PKG_BUILD_DEPENDS:=samba4/host libtasn1/host
+PKG_BUILD_DEPENDS:=samba4/host libtasn1/host perl/host
 
 PKG_CONFIG_DEPENDS:= \
        CONFIG_SAMBA4_SERVER_NETBIOS \
        CONFIG_SAMBA4_SERVER_AVAHI \
+       CONFIG_SAMBA4_SERVER_QUOTAS \
        CONFIG_SAMBA4_SERVER_VFS \
        CONFIG_SAMBA4_SERVER_VFSX \
        CONFIG_SAMBA4_SERVER_AD_DC \
@@ -120,13 +123,13 @@ define Package/samba4-utils
 endef
 
 define Package/samba4-utils/description
-  installs: smbstatus smbtree mvxattr smbtar smbcquotas
+  installs: smbstatus smbtree mvxattr smbtar (smbcquotas)
 
   Utilities collection
 endef
 
-TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
+TARGET_CFLAGS += $(FPIC)
+TARGET_LDFLAGS += -Wl,--as-needed
 # dont mess with sambas private rpath!
 RSTRIP:=:
 
@@ -177,7 +180,6 @@ CONFIGURE_ARGS += \
                --without-automount \
                --without-iconv \
                --without-lttng \
-               --without-ntvfs-fileserver \
                --without-pam \
                --without-systemd \
                --without-utmp \
@@ -202,7 +204,6 @@ HOST_CONFIGURE_ARGS += \
                --without-automount \
                --without-iconv \
                --without-lttng \
-               --without-ntvfs-fileserver \
                --without-pam \
                --without-systemd \
                --without-utmp \
@@ -214,7 +215,7 @@ HOST_CONFIGURE_ARGS += \
 
 HOST_CONFIGURE_ARGS += --disable-avahi --without-quotas --without-acl-support --without-winbind \
        --without-ad-dc --without-json --without-libarchive --disable-python --nopyc --nopyo \
-       --without-dnsupdate --without-ads --without-ldap --without-ldb-lmdb
+       --without-ads --without-ldap --without-ldb-lmdb
 
 # Optional AES-NI support - https://lists.samba.org/archive/samba-technical/2017-September/122738.html
 # Support for Nettle wasn't comitted
@@ -231,7 +232,7 @@ CONFIGURE_ARGS += \
                --with-privatedir=/etc/samba
 
 # features
-ifeq ($(CONFIG_SAMBA4_SERVER_VFS),y)
+ifeq ($(CONFIG_SAMBA4_SERVER_QUOTAS),y)
        CONFIGURE_ARGS += --with-quotas
 else
        CONFIGURE_ARGS += --without-quotas
@@ -246,7 +247,7 @@ ifeq ($(CONFIG_SAMBA4_SERVER_AD_DC),y)
        CONFIGURE_ARGS += --without-winbind --without-ldb-lmdb --with-acl-support
 else
        CONFIGURE_ARGS += --without-winbind --without-ads --without-ldap --without-ldb-lmdb --without-ad-dc \
-               --without-json --without-libarchive --disable-python --nopyc --nopyo --without-dnsupdate --without-acl-support
+               --without-json --without-libarchive --disable-python --nopyc --nopyo --without-acl-support
 endif
 
 SAMBA4_PDB_MODULES :=pdb_smbpasswd,pdb_tdbsam,
@@ -258,7 +259,10 @@ ifdef CONFIG_KERNEL_IO_URING
        SAMBA4_VFS_MODULES_SHARED :=$(SAMBA4_VFS_MODULES_SHARED)vfs_io_uring,
 endif
 ifeq ($(CONFIG_SAMBA4_SERVER_VFS),y)
-       SAMBA4_VFS_MODULES_SHARED :=$(SAMBA4_VFS_MODULES_SHARED)vfs_fruit,vfs_shadow_copy2,vfs_recycle,vfs_fake_perms,vfs_readonly,vfs_cap,vfs_offline,vfs_crossrename,vfs_catia,vfs_streams_xattr,vfs_xattr_tdb,vfs_default_quota,vfs_widelinks,
+       SAMBA4_VFS_MODULES_SHARED :=$(SAMBA4_VFS_MODULES_SHARED)vfs_fruit,vfs_shadow_copy2,vfs_recycle,vfs_fake_perms,vfs_readonly,vfs_cap,vfs_offline,vfs_crossrename,vfs_catia,vfs_streams_xattr,vfs_xattr_tdb,vfs_widelinks,
+ifeq ($(CONFIG_SAMBA4_SERVER_QUOTAS),y)
+       SAMBA4_VFS_MODULES_SHARED :=$(SAMBA4_VFS_MODULES_SHARED)vfs_default_quota,
+endif
 ifdef CONFIG_PACKAGE_kmod-fs-btrfs
        SAMBA4_VFS_MODULES_SHARED :=$(SAMBA4_VFS_MODULES_SHARED)vfs_btrfs,
 endif
@@ -309,6 +313,7 @@ CONFIGURE_ARGS += --private-libraries=$(SYSTEM_PRIVATE_BUNDLED_LIBS)
 
 export COMPILE_ET=$(STAGING_DIR_HOSTPKG)/bin/compile_et_samba
 export ASN1_COMPILE=$(STAGING_DIR_HOSTPKG)/bin/asn1_compile_samba
+export PYTHONHASHSEED=1
 
 # make sure we use the hostpkg build toolset and we need to find host 'yapp'
 HOST_CONFIGURE_VARS+= \
@@ -327,6 +332,9 @@ define Host/Prepare
        $(call Host/Prepare/Default)
        $(SED) 's,mandatory=True,mandatory=False,g' $(HOST_BUILD_DIR)/wscript_configure_system_gnutls
        $(SED) 's,gnutls_version =.*,gnutls_version = gnutls_min_required_version,g' $(HOST_BUILD_DIR)/wscript_configure_system_gnutls
+       $(SED) 's,gnutls_version_str.*,gnutls_version_str = "3.7.7",g' $(HOST_BUILD_DIR)/wscript_configure_system_gnutls
+       $(SED) 's,(gnutls_version > .*,(parse_version(gnutls_version) > parse_version("3.6.10")):,g' $(HOST_BUILD_DIR)/wscript_configure_system_gnutls
+       $(SED) 's,(gnutls_version < .*,(parse_version(gnutls_version) < parse_version("3.5.2")):,g' $(HOST_BUILD_DIR)/wscript_configure_system_gnutls
 endef
 define Host/Compile
        (cd $(HOST_BUILD_DIR); \
@@ -403,7 +411,7 @@ endef
 define Package/samba4-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{smbstatus,smbtree,mvxattr,smbtar} $(1)/usr/bin/
-ifeq ($(CONFIG_SAMBA4_SERVER_VFS),y)
+ifeq ($(CONFIG_SAMBA4_SERVER_QUOTAS),y)
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/smbcquotas $(1)/usr/bin/
 endif
 endef
diff --git a/net/samba4/patches/001-samba-4.4.0-pam.patch b/net/samba4/patches/001-samba-4.4.0-pam.patch
deleted file mode 100644 (file)
index 72de066..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/source3/wscript
-+++ b/source3/wscript
-@@ -885,7 +885,7 @@ msg.msg_accrightslen = sizeof(fd);
-         if conf.env.with_iconv:
-             conf.DEFINE('HAVE_ICONV', 1)
--    if Options.options.with_pam:
-+    if Options.options.with_pam != False:
-         use_pam=True
-         conf.CHECK_HEADERS('security/pam_appl.h pam/pam_appl.h')
-         if not conf.CONFIG_SET('HAVE_SECURITY_PAM_APPL_H') and not conf.CONFIG_SET('HAVE_PAM_PAM_APPL_H'):
-@@ -962,6 +962,17 @@ int i; i = PAM_RADIO_TYPE;
-                        "or headers not found. Use --without-pam to disable "
-                        "PAM support.");
-+    else:
-+        Logs.warn("PAM disabled")
-+        use_pam=False
-+        conf.undefine('WITH_PAM')
-+        conf.undefine('WITH_PAM_MODULES')
-+        conf.undefine('HAVE_SECURITY_PAM_APPL_H')
-+        conf.undefine('PAM_RHOST')
-+        conf.undefine('PAM_TTY')
-+        conf.undefine('HAVE_PAM_PAM_APPL_H')
-+
-+
-     seteuid = False
- #
diff --git a/net/samba4/patches/002-dnsserver-4.7.0.patch b/net/samba4/patches/002-dnsserver-4.7.0.patch
deleted file mode 100644 (file)
index 0c7592f..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-samba: build dnsserver_common code
-
-Just 'install' does not seem to do it.
-
-Upstream-Status: Pending
-
-Signed-off-by: Joe Slater <joe.slater@windriver.com>
-
---- a/source4/dns_server/wscript_build
-+++ b/source4/dns_server/wscript_build
-@@ -4,7 +4,7 @@ bld.SAMBA_LIBRARY('dnsserver_common',
-         source='dnsserver_common.c',
-         deps='samba-util samba-errors ldbsamba clidns',
-         private_library=True,
--        install=bld.AD_DC_BUILD_IS_ENABLED()
-+        enabled=bld.AD_DC_BUILD_IS_ENABLED()
-         )
- bld.SAMBA_MODULE('service_dns',
diff --git a/net/samba4/patches/006-netdb-defines.patch b/net/samba4/patches/006-netdb-defines.patch
deleted file mode 100644 (file)
index a11f8d1..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/nsswitch/wins.c
-+++ b/nsswitch/wins.c
-@@ -40,6 +40,14 @@ static pthread_mutex_t wins_nss_mutex =
- #define INADDRSZ 4
- #endif
-+#ifndef NETDB_INTERNAL
-+#define NETDB_INTERNAL -1
-+#endif
-+
-+#ifndef NETDB_SUCCESS
-+#define NETDB_SUCCESS 0
-+#endif
-+
- NSS_STATUS _nss_wins_gethostbyname_r(const char *hostname,
-                                    struct hostent *he,
-                                    char *buffer,
index 29928976b4a594fe47a4e4de125ffdee15bb57aa..da564e0509a717e944a3c23aa36e2a2cd9c9a043 100644 (file)
@@ -15,12 +15,11 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com>
 
 --- a/lib/tevent/tevent.h
 +++ b/lib/tevent/tevent.h
-@@ -32,6 +32,8 @@
- #include <talloc.h>
+@@ -33,6 +33,7 @@
  #include <sys/time.h>
+ #include <sys/types.h>
  #include <stdbool.h>
 +#include <sys/stat.h>
-+#include <sys/types.h>
  
  /* for old gcc releases that don't have the feature test macro __has_attribute */
  #ifndef __has_attribute
index 284c09d85a677edd885a1a3cd1cb0d29d128bb9b..4f06db369420ddb97abd51019f543cbf3d595d77 100644 (file)
@@ -1,9 +1,9 @@
 --- a/wscript_configure_embedded_heimdal
 +++ b/wscript_configure_embedded_heimdal
-@@ -2,3 +2,14 @@ if not conf.env['FLEX']:
-     conf.fatal("Embedded Heimdal build requires flex but it was not found.  Install flex or use --with-system-mitkrb5 or --with-system-heimdalkrb5")
+@@ -6,3 +6,14 @@ if not conf.env['BISON']:
  
- conf.RECURSE('source4/heimdal_build')
+ conf.define('USING_EMBEDDED_HEIMDAL', 1)
+ conf.RECURSE('third_party/heimdal_build')
 +
 +def check_system_heimdal_binary(name):
 +    if conf.LIB_MAY_BE_BUNDLED(name):
 +
 +check_system_heimdal_binary("compile_et")
 +check_system_heimdal_binary("asn1_compile")
---- a/wscript_configure_system_heimdal
-+++ b/wscript_configure_system_heimdal
-@@ -37,14 +37,6 @@ def check_system_heimdal_lib(name, funct
-     conf.define('USING_SYSTEM_%s' % name.upper(), 1)
-     return True
--def check_system_heimdal_binary(name):
--    if conf.LIB_MAY_BE_BUNDLED(name):
--        return False
--    if not conf.find_program(name, var=name.upper()):
--        return False
--    conf.define('USING_SYSTEM_%s' % name.upper(), 1)
--    return True
--
- check_system_heimdal_lib("com_err", "com_right_r com_err", "com_err.h")
- if check_system_heimdal_lib("roken", "rk_socket_set_reuseaddr", "roken.h"):
-@@ -96,7 +88,4 @@ finally:
- #if conf.CHECK_BUNDLED_SYSTEM('tommath', checkfunctions='mp_init', headers='tommath.h'):
- #    conf.define('USING_SYSTEM_TOMMATH', 1)
--check_system_heimdal_binary("compile_et")
--check_system_heimdal_binary("asn1_compile")
--
- conf.define('USING_SYSTEM_KRB5', 1)
index bbc66a0572d74e2d247edf1adeb8aacc50195a60..b0d08f5c8b5a171f294dee2d0014451b1cadb775 100644 (file)
@@ -1,12 +1,13 @@
 --- a/lib/util/util_paths.c
 +++ b/lib/util/util_paths.c
-@@ -26,6 +26,9 @@
- #include "dynconfig/dynconfig.h"
- #include "lib/util/util_paths.h"
+@@ -28,6 +28,10 @@
  #include "system/passwd.h"
+ #include "system/filesys.h"
 +#if !defined(__GLIBC__) 
 +      #define NSS_BUFLEN_PASSWD 1024
 +#endif
++
  /**
   * @brief Returns an absolute path to a file in the Samba modules directory.
+  *
index ee84f779d3b9fb4e511b9ebfe5df6ff2ada65806..d28f08b9dfd622649cd1ad126c8284c798a79e2e 100644 (file)
@@ -1,8 +1,8 @@
 --- a/python/wscript
 +++ b/python/wscript
-@@ -73,9 +73,9 @@ def configure(conf):
-         for module, package in selftest_pkgs.items():
-             find_third_party_module(conf, module, package)
+@@ -90,9 +90,9 @@ def configure(conf):
+                                       "'python3-iso8601'. Please install "
+                                       "one of the packages.")
  
 -    if not Options.options.without_ad_dc:
 -        for module, package in ad_dc_pkgs.items():
index 351f87bf7242898cc79d88d136dd7b94d89d62fe..df5f56348d4f4f0a6814a7dab14fb4133b077be6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/source3/lib/messages.c
 +++ b/source3/lib/messages.c
-@@ -507,7 +507,7 @@ static NTSTATUS messaging_init_internal(
+@@ -500,7 +500,7 @@ static NTSTATUS messaging_init_internal(
                return NT_STATUS_ACCESS_DENIED;
        }
  
@@ -9,7 +9,7 @@
        if (priv_path == NULL) {
                return NT_STATUS_NO_MEMORY;
        }
-@@ -670,7 +670,7 @@ NTSTATUS messaging_reinit(struct messagi
+@@ -663,7 +663,7 @@ NTSTATUS messaging_reinit(struct messagi
                msg_ctx->per_process_talloc_ctx,
                msg_ctx->event_ctx,
                &msg_ctx->id.unique_id,
index d05e7bdccc487e808fedd3f8b7f81614778a99d4..2bd1e79c652f772a116b86a3d49ccac0a14dec86 100644 (file)
@@ -1,6 +1,6 @@
 --- a/source4/lib/messaging/messaging.c
 +++ b/source4/lib/messaging/messaging.c
-@@ -500,7 +500,7 @@ struct imessaging_context *imessaging_in
+@@ -526,7 +526,7 @@ static struct imessaging_context *imessa
                goto fail;
        }
  
diff --git a/net/samba4/patches/030_wafsamba-replace-echo-n-with-printf.patch b/net/samba4/patches/030_wafsamba-replace-echo-n-with-printf.patch
deleted file mode 100644 (file)
index 7153110..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-From: https://gitlab.com/samba-team/samba/-/commit/29f11005f56ebc2202e7883ea4d9ca7e7a46d9bb
-
-From 29f11005f56ebc2202e7883ea4d9ca7e7a46d9bb Mon Sep 17 00:00:00 2001
-From: "Sergey V. Lobanov" <sergey@lobanov.in>
-Date: Thu, 10 Feb 2022 00:02:17 +0300
-Subject: [PATCH] wafsamba: replace 'echo -n' with printf
-
-This patch makes samba_cross.py compatible with old bash (e.g. 3.2)
-
-Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
-Reviewed-by: Christof Schmitt <cs@samba.org>
-Reviewed-by: Andreas Schneider <asn@samba.org>
-
-Autobuild-User(master): Andreas Schneider <asn@cryptomilk.org>
-Autobuild-Date(master): Fri Feb 11 07:58:57 UTC 2022 on sn-devel-184
----
- buildtools/wafsamba/samba_cross.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/buildtools/wafsamba/samba_cross.py
-+++ b/buildtools/wafsamba/samba_cross.py
-@@ -134,7 +134,7 @@ class cross_Popen(Utils.subprocess.Popen
-                 cross_answers_incomplete = True
-                 add_answer(ca_file, msg, ans)
-             (retcode, retstring) = ans
--            args = ['/bin/sh', '-c', "echo -n '%s'; exit %d" % (retstring, retcode)]
-+            args = ['/bin/sh', '-c', "printf %%s '%s'; exit %d" % (retstring, retcode)]
-         real_Popen.__init__(*(obj, args), **kw)
index 00c69bcc5064e87946db8cb91f9fd7c64ed30265..766fefc522b1ef95337c94fadcdeb33a509fc757 100644 (file)
@@ -1,6 +1,6 @@
 --- a/lib/replace/wscript
 +++ b/lib/replace/wscript
-@@ -416,22 +416,13 @@ def configure(conf):
+@@ -434,22 +434,13 @@ def configure(conf):
  
      conf.CHECK_FUNCS('prctl dirname basename')
  
@@ -29,7 +29,7 @@
  
      conf.CHECK_CODE('''
                  struct ucred cred;
-@@ -817,9 +808,6 @@ syscall(SYS_copy_file_range,0,NULL,0,NUL
+@@ -832,9 +823,6 @@ syscall(SYS_copy_file_range,0,NULL,0,NUL
  
      # look for a method of finding the list of network interfaces
      for method in ['HAVE_IFACE_GETIFADDRS', 'HAVE_IFACE_AIX', 'HAVE_IFACE_IFCONF', 'HAVE_IFACE_IFREQ']:
@@ -39,7 +39,7 @@
          if conf.CHECK_CODE('''
                             #define %s 1
                             #define NO_CONFIG_H 1
-@@ -832,7 +820,7 @@ syscall(SYS_copy_file_range,0,NULL,0,NUL
+@@ -847,7 +835,7 @@ syscall(SYS_copy_file_range,0,NULL,0,NUL
                             #include "tests/getifaddrs.c"
                             ''' % method,
                             method,
@@ -48,7 +48,7 @@
                             addmain=False,
                             execute=True):
              break
-@@ -880,7 +868,6 @@ def build(bld):
+@@ -895,7 +883,6 @@ def build(bld):
                  break
  
      extra_libs = ''
index 14a010c426055c09f52c08c229da7348eaf610a8..e680e91ba33a919313d73e7ef1d039cc0e8080a7 100644 (file)
@@ -1,23 +1,31 @@
 --- a/lib/util/wscript_configure
 +++ b/lib/util/wscript_configure
-@@ -11,13 +11,13 @@ conf.CHECK_FUNCS_IN('backtrace backtrace
+@@ -12,17 +12,17 @@ conf.CHECK_FUNCS_IN('backtrace backtrace
  conf.CHECK_HEADERS('execinfo.h')
  
  conf.SET_TARGET_TYPE('LIBUNWIND', 'EMPTY')
--if conf.check_cfg(package='libunwind-generic',
--                  args='--cflags --libs',
--                  msg='Checking for libunwind',
--                  uselib_store='LIBUNWIND',
--                  mandatory=False):
--    if conf.CHECK_HEADERS('libunwind.h'):
--        conf.SET_TARGET_TYPE('LIBUNWIND', 'SYSLIB')
-+# if conf.check_cfg(package='libunwind-generic',
-+                  # args='--cflags --libs',
-+                  # msg='Checking for libunwind',
-+                  # uselib_store='LIBUNWIND',
-+                  # mandatory=False):
-+    # if conf.CHECK_HEADERS('libunwind.h'):
-+        # conf.SET_TARGET_TYPE('LIBUNWIND', 'SYSLIB')
- conf.CHECK_STRUCTURE_MEMBER('struct statvfs', 'f_frsize', define='HAVE_FRSIZE', headers='sys/statvfs.h')
+-if Options.options.with_libunwind:
+-    if conf.check_cfg(package='libunwind-generic',
+-                      args='--cflags --libs',
+-                      msg='Checking for libunwind',
+-                      uselib_store='LIBUNWIND',
+-                      mandatory=False):
+-        if conf.CHECK_HEADERS('libunwind.h'):
+-            conf.SET_TARGET_TYPE('LIBUNWIND', 'SYSLIB')
+-    else:
+-        raise Errors.WafError('--with-libunwind specified but libunwind not found')
+-elif Options.options.with_libunwind == None:
++#if Options.options.with_libunwind:
++    #if conf.check_cfg(package='libunwind-generic',
++                      #args='--cflags --libs',
++                      #msg='Checking for libunwind',
++                      #uselib_store='LIBUNWIND',
++                      #mandatory=False):
++        #if conf.CHECK_HEADERS('libunwind.h'):
++            #conf.SET_TARGET_TYPE('LIBUNWIND', 'SYSLIB')
++    #else:
++        #raise Errors.WafError('--with-libunwind specified but libunwind not found')
++if Options.options.with_libunwind == None:
+     if not conf.CONFIG_SET('HAVE_BACKTRACE_SYMBOLS') \
+        and not Options.options.disable_fault_handling:
+         raise Errors.WafError(
diff --git a/net/samba4/patches/105-perl-json-pp.patch b/net/samba4/patches/105-perl-json-pp.patch
new file mode 100644 (file)
index 0000000..feb8aaa
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/third_party/heimdal/cf/make-proto.pl
++++ b/third_party/heimdal/cf/make-proto.pl
+@@ -4,7 +4,7 @@
+ use Getopt::Std;
+ use File::Compare;
+-use JSON;
++use JSON::PP;
+ my $comment = 0;
+ my $doxygen = 0;
+@@ -70,7 +70,7 @@ if($opt_x) {
+     my $EXP;
+     local $/;
+     open(EXP, '<', $opt_x) || die "open ${opt_x}";
+-    my $obj = JSON->new->utf8->decode(<EXP>);
++    my $obj = JSON::PP->new->utf8->decode(<EXP>);
+     close $EXP;
+     foreach my $x (keys %$obj) {
index 5d9af17e12533a1c65e9ca8dab29377cba179509..0714416f88c3cdc2c11ea7ab20c9e95ec842c532 100644 (file)
@@ -36,3 +36,5 @@ Checking for the maximum value of the 'time_t' type: OK
 Checking whether the realpath function allows a NULL argument: OK
 Checking for ftruncate extend: OK
 getcwd takes a NULL argument: OK
+Checking for readlink breakage: OK
+Checking for gnutls fips mode support: NO
\ No newline at end of file
index 0d57fbc3a1c020f7d338761c6b4cf200914f72dc..e0635f7a8d93684be079aa62cbc585bfe96cea54 100644 (file)
@@ -39,3 +39,5 @@ getcwd takes a NULL argument: OK
 Checking whether setreuid is available: NO
 Checking whether setresuid is available: NO
 Checking whether seteuid is available: NO
+Checking for readlink breakage: OK
+Checking for gnutls fips mode support: NO
\ No newline at end of file
index df5f77bbca26fd64447dba9362a14594a95a8038..9d07b6f27bbc1b6ff77983a3158f599c88b9b369 100644 (file)
@@ -36,3 +36,5 @@ Checking for the maximum value of the 'time_t' type: NO
 Checking whether the realpath function allows a NULL argument: OK
 Checking for ftruncate extend: OK
 getcwd takes a NULL argument: OK
+Checking for readlink breakage: OK
+Checking for gnutls fips mode support: NO
\ No newline at end of file
index df5f77bbca26fd64447dba9362a14594a95a8038..9d07b6f27bbc1b6ff77983a3158f599c88b9b369 100644 (file)
@@ -36,3 +36,5 @@ Checking for the maximum value of the 'time_t' type: NO
 Checking whether the realpath function allows a NULL argument: OK
 Checking for ftruncate extend: OK
 getcwd takes a NULL argument: OK
+Checking for readlink breakage: OK
+Checking for gnutls fips mode support: NO
\ No newline at end of file
index df5f77bbca26fd64447dba9362a14594a95a8038..9d07b6f27bbc1b6ff77983a3158f599c88b9b369 100644 (file)
@@ -36,3 +36,5 @@ Checking for the maximum value of the 'time_t' type: NO
 Checking whether the realpath function allows a NULL argument: OK
 Checking for ftruncate extend: OK
 getcwd takes a NULL argument: OK
+Checking for readlink breakage: OK
+Checking for gnutls fips mode support: NO
\ No newline at end of file
index 04b93e589531e7c3a97b73e8190107aa5183f21f..e8877211164799fe4f4b18f53a14be4c5f1e083b 100644 (file)
@@ -36,3 +36,5 @@ Checking for the maximum value of the 'time_t' type: NO
 Checking whether the realpath function allows a NULL argument: OK
 Checking for ftruncate extend: OK
 getcwd takes a NULL argument: OK
+Checking for readlink breakage: OK
+Checking for gnutls fips mode support: NO
\ No newline at end of file
index 86be3763bb8863baa86fa48910f66e8703295280..73f77af37d519adc6ea7c751d414bb106dc7581d 100644 (file)
@@ -36,3 +36,5 @@ Checking for the maximum value of the 'time_t' type: OK
 Checking whether the realpath function allows a NULL argument: OK
 Checking for ftruncate extend: OK
 getcwd takes a NULL argument: OK
+Checking for readlink breakage: OK
+Checking for gnutls fips mode support: NO
\ No newline at end of file
index 86be3763bb8863baa86fa48910f66e8703295280..73f77af37d519adc6ea7c751d414bb106dc7581d 100644 (file)
@@ -36,3 +36,5 @@ Checking for the maximum value of the 'time_t' type: OK
 Checking whether the realpath function allows a NULL argument: OK
 Checking for ftruncate extend: OK
 getcwd takes a NULL argument: OK
+Checking for readlink breakage: OK
+Checking for gnutls fips mode support: NO
\ No newline at end of file
index 04b93e589531e7c3a97b73e8190107aa5183f21f..e8877211164799fe4f4b18f53a14be4c5f1e083b 100644 (file)
@@ -36,3 +36,5 @@ Checking for the maximum value of the 'time_t' type: NO
 Checking whether the realpath function allows a NULL argument: OK
 Checking for ftruncate extend: OK
 getcwd takes a NULL argument: OK
+Checking for readlink breakage: OK
+Checking for gnutls fips mode support: NO
\ No newline at end of file
index 3f1b18fd4417fd9c02624634349bff3a7498e07e..85a105acbd9797564f266c18933fd4f92ba39c08 100644 (file)
@@ -36,3 +36,5 @@ Checking for the maximum value of the 'time_t' type: NO
 Checking whether the realpath function allows a NULL argument: OK
 Checking for ftruncate extend: OK
 getcwd takes a NULL argument: OK
+Checking for readlink breakage: OK
+Checking for gnutls fips mode support: NO
\ No newline at end of file
index 5d9af17e12533a1c65e9ca8dab29377cba179509..0714416f88c3cdc2c11ea7ab20c9e95ec842c532 100644 (file)
@@ -36,3 +36,5 @@ Checking for the maximum value of the 'time_t' type: OK
 Checking whether the realpath function allows a NULL argument: OK
 Checking for ftruncate extend: OK
 getcwd takes a NULL argument: OK
+Checking for readlink breakage: OK
+Checking for gnutls fips mode support: NO
\ No newline at end of file
diff --git a/net/samba4/waf-cross-answers/riscv64.txt b/net/samba4/waf-cross-answers/riscv64.txt
new file mode 100644 (file)
index 0000000..0714416
--- /dev/null
@@ -0,0 +1,40 @@
+Checking uname sysname type: "Linux"
+Checking simple C program: "hello world"
+rpath library support: OK
+-Wl,--version-script support: OK
+Checking getconf LFS_CFLAGS: NO
+Checking for large file support without additional flags: OK
+Checking correct behavior of strtoll: OK
+Checking for working strptime: NO
+Checking for C99 vsnprintf: "1"
+Checking for HAVE_SHARED_MMAP: OK
+Checking for HAVE_MREMAP: OK
+Checking for HAVE_INCOHERENT_MMAP: NO
+Checking for HAVE_SECURE_MKSTEMP: OK
+Checking for HAVE_IFACE_GETIFADDRS: OK
+Checking value of NSIG: "65"
+Checking value of _NSIG: "65"
+Checking value of SIGRTMAX: "64"
+Checking value of SIGRTMIN: "35"
+Checking for a 64-bit host to support lmdb: OK
+Checking value of GNUTLS_CIPHER_AES_128_CFB8: "29"
+Checking value of GNUTLS_MAC_AES_CMAC_128: "203"
+Checking errno of iconv for illegal multibyte sequence: OK
+Checking for kernel change notify support: OK
+Checking for Linux kernel oplocks: OK
+Checking for kernel share modes: OK
+Checking whether POSIX capabilities are available: OK
+Checking if can we convert from CP850 to UCS-2LE: OK
+Checking if can we convert from UTF-8 to UCS-2LE: OK
+vfs_fileid checking for statfs() and struct statfs.f_fsid: OK
+Checking whether we can use Linux thread-specific credentials: OK
+Checking whether fcntl locking is available: OK
+Checking whether fcntl lock supports open file description locks: NO
+Checking whether fcntl supports flags to send direct I/O availability signals: OK
+Checking whether fcntl supports setting/geting hints: (-11, "")
+Checking for the maximum value of the 'time_t' type: OK
+Checking whether the realpath function allows a NULL argument: OK
+Checking for ftruncate extend: OK
+getcwd takes a NULL argument: OK
+Checking for readlink breakage: OK
+Checking for gnutls fips mode support: NO
\ No newline at end of file
index 5d9af17e12533a1c65e9ca8dab29377cba179509..0714416f88c3cdc2c11ea7ab20c9e95ec842c532 100644 (file)
@@ -36,3 +36,5 @@ Checking for the maximum value of the 'time_t' type: OK
 Checking whether the realpath function allows a NULL argument: OK
 Checking for ftruncate extend: OK
 getcwd takes a NULL argument: OK
+Checking for readlink breakage: OK
+Checking for gnutls fips mode support: NO
\ No newline at end of file