snort: update to 2.9.15
authorW. Michael Petullo <mike@flyn.org>
Sun, 13 Oct 2019 20:41:24 +0000 (16:41 -0400)
committerW. Michael Petullo <mike@flyn.org>
Sun, 13 Oct 2019 20:41:24 +0000 (16:41 -0400)
Signed-off-by: W. Michael Petullo <mike@flyn.org>
net/snort/Makefile
net/snort/patches/003-include-tirpc.patch [new file with mode: 0644]

index 073ce7891406a37a4d3b6530695862c9a8094bcd..e8dca8079ff241c6510ef992ebe8c051310583f1 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=snort
-PKG_VERSION:=2.9.11.1
-PKG_RELEASE:=8
+PKG_VERSION:=2.9.15
+PKG_RELEASE:=1
 
 PKG_LICENSE:=GPL-2.0
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
@@ -18,7 +18,7 @@ PKG_CPE_ID:=cpe:/a:snort:snort
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.snort.org/downloads/snort/ \
        @SF/$(PKG_NAME)
-PKG_HASH:=9f6b3aeac5a109f55504bd370564ac431cb1773507929dc461626898f33f46cd
+PKG_HASH:=bfb437746446ef72a03c501db13cd6da5edd2b41f55c80c437ba288be6da7dba
 
 PKG_BUILD_DEPENDS:=libtirpc
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)/$(PKG_NAME)-$(PKG_VERSION)
@@ -31,7 +31,7 @@ define Package/snort
   SUBMENU:=Firewall
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libdaq +libdnet +libnghttp2 +libopenssl +libpcap +libpcre +libpthread +libuuid +zlib +SNORT_LZMA:liblzma
+  DEPENDS:=+libdaq +libdnet +libnghttp2 +libopenssl +libpcap +libpcre +libpthread +libtirpc +libuuid +zlib +luajit +SNORT_LZMA:liblzma
   TITLE:=Lightweight Network Intrusion Detection System
   URL:=http://www.snort.org/
   MENU:=1
diff --git a/net/snort/patches/003-include-tirpc.patch b/net/snort/patches/003-include-tirpc.patch
new file mode 100644 (file)
index 0000000..439287d
--- /dev/null
@@ -0,0 +1,11 @@
+diff -u --recursive snort-2.9.15-vanilla/src/dynamic-preprocessors/appid/service_plugins/service_rpc.c snort-2.9.15/src/dynamic-preprocessors/appid/service_plugins/service_rpc.c
+--- snort-2.9.15-vanilla/src/dynamic-preprocessors/appid/service_plugins/service_rpc.c 2019-10-03 02:42:31.000000000 -0400
++++ snort-2.9.15/src/dynamic-preprocessors/appid/service_plugins/service_rpc.c 2019-10-13 16:16:37.146329944 -0400
+@@ -32,6 +32,7 @@
+ #include "flow.h"
+ #include "service_api.h"
++#include <tirpc/rpc/rpcent.h>
+ #if defined(FREEBSD) || defined(OPENBSD)
+ #include "rpc/rpc.h"
+ #endif