sedutil: Add new package
authorJavier Marcet <javier@marcet.info>
Wed, 8 Feb 2023 13:40:10 +0000 (14:40 +0100)
committerRosen Penev <rosenp@gmail.com>
Mon, 1 May 2023 10:39:06 +0000 (13:39 +0300)
The Drive Trust Alliance Self Encrypting Drive Utility

Signed-off-by: Javier Marcet <javier@marcet.info>
utils/sedutil/Makefile [new file with mode: 0644]

diff --git a/utils/sedutil/Makefile b/utils/sedutil/Makefile
new file mode 100644 (file)
index 0000000..9625459
--- /dev/null
@@ -0,0 +1,41 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sedutil
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL=https://github.com/Drive-Trust-Alliance/sedutil
+PKG_SOURCE_DATE:=2022-12-27
+PKG_SOURCE_VERSION:=7a0cda7f60cce346f72466e61ce006e5ea48fbc0
+PKG_MIRROR_HASH:=e11333bfa0760a46cbebcba35360e0f076e6219eb38ce1545179b8741476668a
+
+PKG_LICENSE_FILES:=README.md
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+
+PKG_FIXUP:=autoreconf
+PKG_BUILD_PARALLEL:=1
+PKG_BUILD_FLAGS:=lto
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/sedutil
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=The Drive Trust Alliance Self Encrypting Drive Utility
+  URL:=https://github.com/Drive-Trust-Alliance/sedutil
+  DEPENDS:=+libstdcpp
+endef
+
+define Package/sedutil/description
+This program and it's accompanying Pre-Boot Authorization image allow you to
+enable the locking in SED's that comply with the TCG OPAL 2.00 standard on bios
+machines.
+endef
+
+define Package/sedutil/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_BUILD_DIR)/{linuxpba,sedutil-cli} $(1)/usr/bin
+endef
+
+$(eval $(call BuildPackage,sedutil))