gstreamer1: enable build options necessary for most applications
authorW. Michael Petullo <mike@flyn.org>
Fri, 21 Aug 2020 22:51:46 +0000 (17:51 -0500)
committerW. Michael Petullo <mike@flyn.org>
Fri, 21 Aug 2020 23:07:26 +0000 (18:07 -0500)
Commit cb058bf changed gstreamer1's build options, and this broke some
applications.

First, -Doption-parsing=false is intended for very specific embedded
applications rather general packages. Please see:

https://github.com/openwrt/packages/pull/8847
https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/388

Second, -Dregistry=false seems to break plugin discovery. Symptoms of
this include broken applications and gst-inspect-1.0 listing zero plugins.

Fixes #13180.

Signed-off-by: W. Michael Petullo <mike@flyn.org>
multimedia/gstreamer1/Makefile

index 4425c6915f4f2dc7194591a91031ebf895e3d6b2..00a2e6e7139c2e0d9a099feb5f367adbee1ed338 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gstreamer1
 PKG_VERSION:=1.17.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=gstreamer-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gstreamer
@@ -118,11 +118,11 @@ GST_VERSION:=1.0
 MESON_ARGS += \
        -Dgst_debug=false \
        -Dgst_parse=true \
-       -Dregistry=false \
+       -Dregistry=true \
        -Dtracer_hooks=false \
        -Dptp-helper-setuid-user=none \
        -Dptp-helper-setuid-group=none \
-       -Doption-parsing=false \
+       -Doption-parsing=true \
        -Dpoisoning=false \
        -Dmemory-alignment=malloc \
        -Dcheck=enabled \