getdns: properly remove libbsd support
authorRosen Penev <rosenp@gmail.com>
Tue, 7 Jul 2020 21:20:01 +0000 (14:20 -0700)
committerRosen Penev <rosenp@gmail.com>
Tue, 7 Jul 2020 21:57:49 +0000 (14:57 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/getdns/Makefile

index f8b41a2cbc3b11e3d3f121840179b7c44f6a5baf..5b307ffda0c0e783a408cac79604c7574667660e 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=getdns
 PKG_VERSION:=1.6.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
@@ -62,7 +62,7 @@ CMAKE_OPTIONS += -DUSE_LIBIDN2=$(if $(CONFIG_GETDNS_ENABLE_IDN_LIBIDN2),ON,OFF)
 # present, otherwise it will use builtin code for these functions. In order to
 # force the use of the built in code and remove the libbsd dependency disable
 # the test for libbsd.
-CMAKE_OPTIONS += -DCMAKE_DISABLE_FIND_PACKAGE_BSD=ON
+CMAKE_OPTIONS += -DBSD_LIBRARY=OFF
 
 define Package/getdns/install
        $(INSTALL_DIR) $(1)/usr/lib