liburcu: Don't build under ARC, not even InstallDev
authorRosen Penev <rosenp@gmail.com>
Sat, 4 Jan 2020 02:54:26 +0000 (18:54 -0800)
committerRosen Penev <rosenp@gmail.com>
Sat, 4 Jan 2020 02:54:26 +0000 (18:54 -0800)
This should finally get rid of buildbot failures.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/liburcu/Makefile

index 401c5db54e59d8ddd8144bf23d98332f0e7717f3..c4ed4ab759b697bf535c0e5ce584027d42e17d5c 100644 (file)
@@ -32,19 +32,21 @@ define Package/liburcu
        CATEGORY:=Libraries
        TITLE:=User-space Read-Copy-Update library
        URL:=https://lttng.org/
-       DEPENDS:=+libpthread @!TARGET_arc770 @!TARGET_archs38
+       DEPENDS:=+libpthread @!arc
 endef
 
 define Package/liburcu/description
        Userspace Read-Copy-Update library.
 endef
 
+ifeq ($(CONFIG_arc),)
 define Build/InstallDev
        $(INSTALL_DIR)                                          $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/urcu*              $(1)/usr/include/
        $(INSTALL_DIR)                                          $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/liburcu*.{a,so*}       $(1)/usr/lib/
 endef
+endif
 
 define Package/liburcu/install
        $(INSTALL_DIR)                                  $(1)/usr/lib