afalg_engine: bump to v1.1.0
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Sun, 19 Jan 2020 18:55:37 +0000 (15:55 -0300)
committerEneas U de Queiroz <cotequeiroz@gmail.com>
Sun, 19 Jan 2020 19:16:25 +0000 (16:16 -0300)
This version is up to 20% faster than 1.0.1.
Build without cryptouser information, which is not available in 19.07.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
libs/afalg_engine/Makefile

index 9da969a4367d4f59c61c39c96e59baf302b7131e..c6456859328bbc256c734b4525e601c4e5032e07 100644 (file)
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=afalg_engine
-PKG_VERSION:=1.0.1
-PKG_RELEASE:=2
+PKG_VERSION:=1.1.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/cotequeiroz/afalg_engine/archive/v$(PKG_VERSION)
-PKG_HASH:=ef3ee1ba3cb4e9145f9a0dea5bc6d3fe6cb7b5b9e68053d474829e84dc1c4988
+PKG_HASH:=0c0304558e9450752656522a8f9036130f4e745c4818f02f92cb8d6c99357ed6
 
 PKG_MAINTAINER:=Eneas U de Queiroz <cotequeiroz@gmail.com>
 PKG_LICENSE:=Apache-2.0
@@ -56,6 +56,7 @@ endef
 
 CMAKE_OPTIONS += \
        -DOPENSSL_ENGINES_DIR=/usr/lib/$(ENGINES_DIR) \
+       -DUSE_CRYPTOUSER=OFF \
        -DUSE_ZERO_COPY=$(if $(CONFIG_AFALG_ZERO_COPY),ON,OFF)
 
 define Package/libopenssl-afalg_sync/install