krb5: update depends, adapt FS#1310
authorAndy Walsh <andy.walsh44+github@gmail.com>
Mon, 29 Jan 2018 16:57:25 +0000 (17:57 +0100)
committerJo-Philipp Wich <jo@mein.io>
Mon, 30 Jul 2018 14:11:34 +0000 (16:11 +0200)
Signed-off-by: Andy Walsh <andy.walsh44+github@gmail.com>
(cherry picked from commit ebc41d575903febd2a3cb4928f7529288179a24b)

net/krb5/Makefile

index 8d76a36dadedc847197812ab6b878161bda76ad3..f63dd21f9be79c0a227951125c8439edad4a5274 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=krb5
 PKG_VERSION:=1.16
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 
@@ -40,7 +40,7 @@ define Package/krb5-libs
        SECTION:=net
        CATEGORY:=Network
        TITLE:=Kerberos
-       DEPENDS:=+libncurses
+       DEPENDS:=+libncurses +libss +libcomerr
        TITLE:=Kerberos 5 Shared Libraries
        URL:=http://web.mit.edu/kerberos/
 endef
@@ -58,7 +58,8 @@ define Package/krb5-client
 endef
 
 define Package/krb5/description
-       Kerberos
+  Kerberos is a network authentication protocol. 
+  It is designed to provide strong authentication for client/server applications by using secret-key cryptography.
 endef
 
 CONFIGURE_PATH = ./src
@@ -72,13 +73,18 @@ CONFIGURE_VARS += \
        ac_cv_file__etc_TIMEZONE=no
 
 CONFIGURE_ARGS += \
+       --localstatedir=/etc \
+       --with-system-ss \
+       --with-system-et \
        --without-system-verto \
        --without-tcl \
+       --without-tls-impl \
        --without-libedit \
-       --localstatedir=/etc \
-       --with-size-optimizations \
+       --without-readline \
        --disable-rpath \
-       --without-krb5-config
+       --disable-pkinit \
+       --with-size-optimizations \
+       --with-crypto-impl=builtin
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include