git: update to 2.2.0
authorPeter Wagner <tripolar@gmx.at>
Thu, 4 Dec 2014 09:12:32 +0000 (10:12 +0100)
committerPeter Wagner <tripolar@gmx.at>
Thu, 4 Dec 2014 09:12:32 +0000 (10:12 +0100)
Signed-off-by: Peter Wagner <tripolar@gmx.at>
net/git/Makefile
net/git/patches/100-convert_builtin.patch

index e36790ece207fa1dc29d11c524fb70b0ce3d6989..a909e77fa489da034cfebd36dec7011c90537ea8 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=git
-PKG_VERSION:=2.1.0
-PKG_RELEASE:=2
+PKG_VERSION:=2.2.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/software/scm/git/
-PKG_MD5SUM:=47b1f55d9a16be112f7ae2c778a9b30c
+PKG_MD5SUM:=5c9d20582297f8f24606fe49f515b584
 
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
index e883921e54a0b6597c6a00216dd543d058d191b2..e7ded54dac3b54c1b1307363e1e478f216c6c5f8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -533,16 +533,7 @@ EXTRA_PROGRAMS =
+@@ -529,16 +529,7 @@ EXTRA_PROGRAMS =
  # ... and all the rest that could be moved out of bindir to gitexecdir
  PROGRAMS += $(EXTRA_PROGRAMS)
  
@@ -18,7 +18,7 @@
  
  # Binary suffix, set to .exe for Windows builds
  X =
-@@ -1007,6 +998,12 @@ BUILTIN_OBJS += builtin/verify-commit.o
+@@ -887,6 +878,12 @@ BUILTIN_OBJS += builtin/verify-commit.o
  BUILTIN_OBJS += builtin/verify-pack.o
  BUILTIN_OBJS += builtin/verify-tag.o
  BUILTIN_OBJS += builtin/write-tree.o
@@ -31,7 +31,7 @@
  
  GITLIBS = $(LIB_FILE) $(XDIFF_LIB)
  EXTLIBS =
-@@ -1174,7 +1171,7 @@ endif
+@@ -1049,7 +1046,7 @@ endif
  EXTLIBS += -lz
  
  ifndef NO_OPENSSL
@@ -40,7 +40,7 @@
        ifdef OPENSSLDIR
                BASIC_CFLAGS += -I$(OPENSSLDIR)/include
                OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib)
-@@ -2067,10 +2064,6 @@ endif
+@@ -1895,10 +1892,6 @@ endif
  git-%$X: %.o GIT-LDFLAGS $(GITLIBS)
        $(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS)
  
@@ -51,7 +51,7 @@
  git-http-fetch$X: http.o http-walker.o http-fetch.o GIT-LDFLAGS $(GITLIBS)
        $(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
                $(LIBS) $(CURL_LIBCURL)
-@@ -2388,24 +2381,22 @@ endif
+@@ -2216,24 +2209,22 @@ endif
        bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
        execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
        { test "$$bindir/" = "$$execdir/" || \
@@ -80,7 +80,7 @@
        done && \
 --- a/builtin.h
 +++ b/builtin.h
-@@ -137,5 +137,11 @@ extern int cmd_verify_pack(int argc, con
+@@ -138,5 +138,11 @@ extern int cmd_verify_pack(int argc, con
  extern int cmd_show_ref(int argc, const char **argv, const char *prefix);
  extern int cmd_pack_refs(int argc, const char **argv, const char *prefix);
  extern int cmd_replace(int argc, const char **argv, const char *prefix);
 +#include "../upload-pack.c"
 --- a/daemon.c
 +++ b/daemon.c
-@@ -1119,7 +1119,7 @@ static int serve(struct string_list *lis
+@@ -1096,7 +1096,7 @@ static int serve(struct string_list *lis
        return service_loop(&socklist);
  }
  
  {
        int listen_port = 0;
        struct string_list listen_addr = STRING_LIST_INIT_NODUP;
-@@ -1315,12 +1315,13 @@
+@@ -1292,12 +1292,13 @@ int main(int argc, char **argv)
                store_pid(pid_file);
  
        /* prepare argv for serving-processes */
  }
 --- a/fast-import.c
 +++ b/fast-import.c
-@@ -3343,7 +3343,7 @@ static void parse_argv(void)
+@@ -3350,7 +3350,7 @@ static void parse_argv(void)
                read_marks();
  }
  
        { "index-pack", cmd_index_pack, RUN_SETUP_GENTLY },
        { "init", cmd_init_db, NO_SETUP },
        { "init-db", cmd_init_db, NO_SETUP },
-@@ -461,6 +464,7 @@ static struct cmd_struct commands[] = {
+@@ -462,6 +465,7 @@ static struct cmd_struct commands[] = {
        { "revert", cmd_revert, RUN_SETUP | NEED_WORK_TREE },
        { "rm", cmd_rm, RUN_SETUP },
        { "send-pack", cmd_send_pack, RUN_SETUP },
        { "shortlog", cmd_shortlog, RUN_SETUP_GENTLY | USE_PAGER },
        { "show", cmd_show, RUN_SETUP },
        { "show-branch", cmd_show_branch, RUN_SETUP },
-@@ -477,6 +481,7 @@ static struct cmd_struct commands[] = {
+@@ -478,6 +482,7 @@ static struct cmd_struct commands[] = {
        { "update-server-info", cmd_update_server_info, RUN_SETUP },
        { "upload-archive", cmd_upload_archive },
        { "upload-archive--writer", cmd_upload_archive_writer },
        { "verify-pack", cmd_verify_pack },
 --- a/http-backend.c
 +++ b/http-backend.c
-@@ -566,7 +566,7 @@ static struct service_cmd {
+@@ -557,7 +557,7 @@ static struct service_cmd {
        {"POST", "/git-receive-pack$", service_rpc}
  };
  
        char *dir;
 --- a/imap-send.c
 +++ b/imap-send.c
-@@ -1365,7 +1365,7 @@ static int git_imap_config(const char *k
-       return 0;
+@@ -1338,7 +1338,7 @@ static void git_imap_config(void)
+       git_config_get_string("imap.authmethod", &server.auth_method);
  }
  
 -int main(int argc, char **argv)
        const char **user_argv;
 --- a/upload-pack.c
 +++ b/upload-pack.c
-@@ -790,7 +790,7 @@ static int upload_pack_config(const char
+@@ -791,7 +791,7 @@ static int upload_pack_config(const char
        return parse_hide_refs_config(var, value, "uploadpack");
  }