python,python3: move .exe removal in `python-package-install.sh` script
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 4 Feb 2019 14:10:08 +0000 (16:10 +0200)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 4 Feb 2019 14:38:12 +0000 (16:38 +0200)
It's a common operation for both Python & Python3, so move it to the
script `python-package-install.sh` script.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/python-package-install.sh
lang/python/python-package.mk
lang/python/python3-package.mk

index e5f6ec89389f23cb38993e4cec3182b98ac5380e..ae6f2ef770beaddd2a83be1c6dc1fb0e0c8f057c 100644 (file)
@@ -47,6 +47,8 @@ python="$4"
 mode="$5"
 filespec="$6"
 
+find "$src_dir" -name "*\.exe" | xargs rm -f
+
 process_filespec "$src_dir" "$dst_dir" "$filespec" || {
        echo "process filespec error-ed"
        exit 1
index 66a49298370efe3b4825528dbb34b41b08c9df6e..af35dcdb32b096dda977c1eeb24cdb289d5184e5 100644 (file)
@@ -69,7 +69,6 @@ define PyPackage
 
   define Package/$(1)/install
        $(call PyPackage/$(1)/install,$$(1))
-       find $(PKG_INSTALL_DIR) -name "*\.exe" | xargs rm -f
        $(SHELL) $(python_mk_path)python-package-install.sh "2" \
                "$(PKG_INSTALL_DIR)" "$$(1)" \
                "$(HOST_PYTHON_BIN)" "$$(2)" \
@@ -113,7 +112,6 @@ define Build/Compile/PyMod
                cd $(PKG_BUILD_DIR)/$(strip $(1)), \
                ./setup.py $(2), \
                $(3))
-       find $(PKG_INSTALL_DIR) -name "*\.exe" | xargs rm -f
 endef
 
 PYTHON_PKG_SETUP_ARGS:=--single-version-externally-managed
index 9e473b5c5d2e8fcfcbd24dd219f1c1178bada2bc..9cfa7673e7281f19e19d6a8bb5d42c632931cb88 100644 (file)
@@ -68,7 +68,6 @@ define Py3Package
 
   define Package/$(1)/install
        $(call Py3Package/$(1)/install,$$(1))
-       find $(PKG_INSTALL_DIR) -name "*\.exe" | xargs rm -f
        $(SHELL) $(python3_mk_path)python-package-install.sh "3" \
                "$(PKG_INSTALL_DIR)" "$$(1)" \
                "$(HOST_PYTHON3_BIN)" "$$(2)" \
@@ -112,7 +111,6 @@ define Build/Compile/Py3Mod
                cd $(PKG_BUILD_DIR)/$(strip $(1)), \
                ./setup.py $(2), \
                $(3))
-       find $(PKG_INSTALL_DIR) -name "*\.exe" | xargs rm -f
 endef
 
 PYTHON3_PKG_SETUP_ARGS:=--single-version-externally-managed