lxc: add configuration section
authorLuka Perkov <luka@openwrt.org>
Wed, 10 Sep 2014 12:39:17 +0000 (14:39 +0200)
committerLuka Perkov <luka@openwrt.org>
Wed, 10 Sep 2014 23:02:04 +0000 (01:02 +0200)
Signed-off-by: Luka Perkov <luka@openwrt.org>
utils/lxc/Config.in [new file with mode: 0644]
utils/lxc/Makefile

diff --git a/utils/lxc/Config.in b/utils/lxc/Config.in
new file mode 100644 (file)
index 0000000..c52ba53
--- /dev/null
@@ -0,0 +1,15 @@
+menu "Configuration"
+        depends on PACKAGE_lxc
+
+config LXC_KERNEL_OPTIONS
+       bool "Enable kernel support for LXC"
+       default n
+       select KERNEL_CGROUPS
+       select KERNEL_NAMESPACES
+       select KERNEL_LXC_MISC
+       help
+         Select needed kernel options for LXC related utilities. Options
+         include cgroups, namespaces and other miscellaneous options. These
+         options unfortunately can not be installed as a module.
+
+endmenu
index a613352df9d5e2df9bb7ad0d32d94952817d896c..97d79835ead49967de3d0ebcee44a766e86edd00 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lxc
 PKG_VERSION:=1.0.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://linuxcontainers.org/downloads/
@@ -49,6 +49,10 @@ define Package/lxc
   MENU:=1
 endef
 
+define Package/lxc/config
+  source "$(SOURCE)/Config.in"
+endef
+
 define Package/lxc/description
  LXC is the userspace control package for Linux Containers, a lightweight
  virtual system mechanism sometimes described as "chroot on steroids".