rsyslog: move from net to admin
authorMatthew Hagan <mnhagan88@gmail.com>
Mon, 15 Nov 2021 09:58:54 +0000 (09:58 +0000)
committerRosen Penev <rosenp@gmail.com>
Tue, 16 Nov 2021 21:27:24 +0000 (13:27 -0800)
Signed-off-by: Matthew Hagan <mnhagan88@gmail.com>
admin/rsyslog/Makefile [new file with mode: 0644]
admin/rsyslog/files/rsyslog.conf [new file with mode: 0644]
admin/rsyslog/files/rsyslog.init [new file with mode: 0644]
net/rsyslog/Makefile [deleted file]
net/rsyslog/files/rsyslog.conf [deleted file]
net/rsyslog/files/rsyslog.init [deleted file]

diff --git a/admin/rsyslog/Makefile b/admin/rsyslog/Makefile
new file mode 100644 (file)
index 0000000..12d3b04
--- /dev/null
@@ -0,0 +1,59 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=rsyslog
+PKG_VERSION:=8.2006.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:= \
+       https://fossies.org/linux/misc \
+       https://www.rsyslog.com/files/download/rsyslog
+PKG_HASH:=d9589e64866f2fdc5636af4cae9d60ebf1e3257bb84b81ee953ede6a05878e97
+
+PKG_MAINTAINER:=
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE_FILES:=COPYING
+PKG_CPE_ID:=cpe:/a:rsyslog:rsyslog
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/rsyslog
+  SECTION:=admin
+  CATEGORY:=Administration
+  TITLE:=Enhanced system logging and kernel message trapping daemons
+  URL:=https://www.rsyslog.com/
+  DEPENDS:=+libestr +libfastjson +libuuid +zlib
+endef
+
+define Package/rsyslog/conffiles
+/etc/rsyslog.conf
+endef
+
+CONFIGURE_ARGS+= \
+       --disable-libgcrypt \
+       --disable-fmhttp \
+       --disable-default-tests \
+       --disable-libsystemd
+
+define Package/rsyslog/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/rsyslogd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/lib/rsyslog
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/rsyslog/* $(1)/usr/lib/rsyslog/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_CONF) ./files/rsyslog.conf $(1)/etc
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/rsyslog.init $(1)/etc/init.d/rsyslog
+endef
+
+$(eval $(call BuildPackage,rsyslog))
diff --git a/admin/rsyslog/files/rsyslog.conf b/admin/rsyslog/files/rsyslog.conf
new file mode 100644 (file)
index 0000000..5aaed41
--- /dev/null
@@ -0,0 +1,18 @@
+module(load="imuxsock")
+module(load="imklog")
+module(load="imudp")
+input(type="imudp" port="514")
+#module(load="imtcp")
+#input(type="imtcp" port="514")
+
+$ActionFileDefaultTemplate RSYSLOG_TraditionalFileFormat
+
+*.info;mail.none;authpriv.none;cron.none  /var/log/messages
+
+authpriv.*                                /var/log/secure
+
+mail.*                                    /var/log/maillog
+
+cron.*                                    /var/log/cron
+
+local7.*                                  /var/log/boot.log
diff --git a/admin/rsyslog/files/rsyslog.init b/admin/rsyslog/files/rsyslog.init
new file mode 100644 (file)
index 0000000..20eb2a4
--- /dev/null
@@ -0,0 +1,12 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2014 OpenWrt.org
+
+START=20
+
+USE_PROCD=1
+
+start_service() {
+       procd_open_instance
+       procd_set_param command /usr/sbin/rsyslogd -n
+       procd_close_instance
+}
diff --git a/net/rsyslog/Makefile b/net/rsyslog/Makefile
deleted file mode 100644 (file)
index 816fc0b..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-#
-# Copyright (C) 2006-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=rsyslog
-PKG_VERSION:=8.2006.0
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:= \
-       https://fossies.org/linux/misc \
-       https://www.rsyslog.com/files/download/rsyslog
-PKG_HASH:=d9589e64866f2fdc5636af4cae9d60ebf1e3257bb84b81ee953ede6a05878e97
-
-PKG_MAINTAINER:=
-PKG_LICENSE:=GPL-3.0-or-later
-PKG_LICENSE_FILES:=COPYING
-PKG_CPE_ID:=cpe:/a:rsyslog:rsyslog
-
-PKG_INSTALL:=1
-PKG_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/rsyslog
-  SECTION:=net
-  CATEGORY:=Network
-  TITLE:=Enhanced system logging and kernel message trapping daemons
-  URL:=https://www.rsyslog.com/
-  DEPENDS:=+libestr +libfastjson +libuuid +zlib
-endef
-
-define Package/rsyslog/conffiles
-/etc/rsyslog.conf
-endef
-
-CONFIGURE_ARGS+= \
-       --disable-libgcrypt \
-       --disable-fmhttp \
-       --disable-default-tests \
-       --disable-libsystemd
-
-define Package/rsyslog/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/rsyslogd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/usr/lib/rsyslog
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/rsyslog/* $(1)/usr/lib/rsyslog/
-       $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_CONF) ./files/rsyslog.conf $(1)/etc
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/rsyslog.init $(1)/etc/init.d/rsyslog
-endef
-
-$(eval $(call BuildPackage,rsyslog))
diff --git a/net/rsyslog/files/rsyslog.conf b/net/rsyslog/files/rsyslog.conf
deleted file mode 100644 (file)
index 5aaed41..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-module(load="imuxsock")
-module(load="imklog")
-module(load="imudp")
-input(type="imudp" port="514")
-#module(load="imtcp")
-#input(type="imtcp" port="514")
-
-$ActionFileDefaultTemplate RSYSLOG_TraditionalFileFormat
-
-*.info;mail.none;authpriv.none;cron.none  /var/log/messages
-
-authpriv.*                                /var/log/secure
-
-mail.*                                    /var/log/maillog
-
-cron.*                                    /var/log/cron
-
-local7.*                                  /var/log/boot.log
diff --git a/net/rsyslog/files/rsyslog.init b/net/rsyslog/files/rsyslog.init
deleted file mode 100644 (file)
index 20eb2a4..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2014 OpenWrt.org
-
-START=20
-
-USE_PROCD=1
-
-start_service() {
-       procd_open_instance
-       procd_set_param command /usr/sbin/rsyslogd -n
-       procd_close_instance
-}