Fix at compilation
authorFlorian Fainelli <florian@openwrt.org>
Sun, 21 Sep 2008 15:09:44 +0000 (15:09 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 21 Sep 2008 15:09:44 +0000 (15:09 +0000)
SVN-Revision: 12643

utils/at/Makefile

index f40c396594947b097ebfade5caa7bc92feb7aed0..f793ffadb92ba5eacdc521a19b9f1cb3a7450301 100644 (file)
@@ -20,6 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/at
   SECTION:=utils
   CATEGORY:=Utilities
+  DEPENDS:=+libelf
   TITLE:=Delayed job execution and batch processing
 endef
 
@@ -30,7 +31,8 @@ define Package/at/description
 endef
 
 export SENDMAIL=/bin/true
-EXTRA_CFLAGS:=-DNEED_YYWRAP -I$(PKG_BUILD_DIR)
+EXTRA_CFLAGS:=-DNEED_YYWRAP -I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include/libelf \
+               -L$(STAGING_DIR)/usr/lib
 CONFIGURE_ARGS+=--with-daemon_username=nobody --with-daemon_groupname=nogroup
 
 define Package/at/install