python3: update to version 3.9.9
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Sat, 4 Dec 2021 22:15:27 +0000 (23:15 +0100)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Sat, 4 Dec 2021 22:15:27 +0000 (23:15 +0100)
- Updated setuptools and pip
- Refreshed patches

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
lang/python/python3-version.mk
lang/python/python3/Makefile
lang/python/python3/patches/003-do-not-run-distutils-tests.patch
lang/python/python3/patches/013-getbuildinfo-date-time-source-date-epoch.patch
lang/python/python3/patches/014-remove-platform-so-suffix.patch
lang/python/python3/patches/016-adjust-config-paths.patch
lang/python/python3/patches/025-choose-python-config-version.patch

index b0772218b0ab6e238bd09bf3922c718ab3b62d4c..791dab6b91d0a45cd3b74c8220c76ff394060cb7 100644 (file)
@@ -8,12 +8,12 @@
 # Note: keep in sync with setuptools & pip
 PYTHON3_VERSION_MAJOR:=3
 PYTHON3_VERSION_MINOR:=9
-PYTHON3_VERSION_MICRO:=7
+PYTHON3_VERSION_MICRO:=9
 
 PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)
 
 PYTHON3_SETUPTOOLS_PKG_RELEASE:=1
 PYTHON3_PIP_PKG_RELEASE:=1
 
-PYTHON3_SETUPTOOLS_VERSION:=57.4.0
-PYTHON3_PIP_VERSION:=21.2.3
+PYTHON3_SETUPTOOLS_VERSION:=58.1.0
+PYTHON3_PIP_VERSION:=21.2.4
index 8eb28aea03869d36b9c3a861752e5084d6505ea4..eeff01a6d16d89567eaae2fa5d4726eb4a766123 100644 (file)
@@ -17,7 +17,7 @@ PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
 # FIXME: if updating, get rid of [1] & [2] asap
-PKG_HASH:=f8145616e68c00041d1a6399b76387390388f8359581abc24432bb969b5e3c57
+PKG_HASH:=06828c04a573c073a4e51c4292a27c1be4ae26621c3edc7cf9318418ce3b6d27
 
 PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
 PKG_LICENSE:=Python/2.0
index 544fdbed8a4c31d37bddc44e8edd9ecac15a7907..2f604a1d5c7d6a401d469357b971ca05f0ff7bb7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.pre.in
 +++ b/Makefile.pre.in
-@@ -1546,6 +1546,7 @@ libinstall:      build_all $(srcdir)/Modules/
+@@ -1545,6 +1545,7 @@ libinstall:      build_all $(srcdir)/Modules/
        $(INSTALL_DATA) `cat pybuilddir.txt`/_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH).py \
                $(DESTDIR)$(LIBDEST); \
        $(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
@@ -8,7 +8,7 @@
        if test -d $(DESTDIR)$(LIBDEST)/distutils/tests; then \
                $(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
                        $(DESTDIR)$(LIBDEST)/distutils/tests ; \
-@@ -1581,6 +1582,7 @@ libinstall:      build_all $(srcdir)/Modules/
+@@ -1580,6 +1581,7 @@ libinstall:      build_all $(srcdir)/Modules/
                $(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt
        -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
                $(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
index 0a987d6b4d89e803ff996fa202bdc30b88609f5f..b3d720d63252c57cdf16766498134791321f227b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.pre.in
 +++ b/Makefile.pre.in
-@@ -774,6 +774,16 @@ regen-all: regen-opcode regen-opcode-tar
+@@ -773,6 +773,16 @@ regen-all: regen-opcode regen-opcode-tar
  ############################################################################
  # Special rules for object files
  
@@ -17,7 +17,7 @@
  Modules/getbuildinfo.o: $(PARSER_OBJS) \
                $(OBJECT_OBJS) \
                $(PYTHON_OBJS) \
-@@ -782,6 +792,8 @@ Modules/getbuildinfo.o: $(PARSER_OBJS) \
+@@ -781,6 +791,8 @@ Modules/getbuildinfo.o: $(PARSER_OBJS) \
                $(DTRACE_OBJS) \
                $(srcdir)/Modules/getbuildinfo.c
        $(CC) -c $(PY_CORE_CFLAGS) \
index 39166073fb86d7e522a6ac5d99875fec6ab90744..d2a77491f3123a6262911ec030a7a0be13ddb1e7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -15390,7 +15390,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
+@@ -15461,7 +15461,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
  $as_echo "$ABIFLAGS" >&6; }
  { $as_echo "$as_me:${as_lineno-$LINENO}: checking SOABI" >&5
  $as_echo_n "checking SOABI... " >&6; }
@@ -11,7 +11,7 @@
  
 --- a/configure.ac
 +++ b/configure.ac
-@@ -4800,7 +4800,7 @@ AC_SUBST(SOABI)
+@@ -4807,7 +4807,7 @@ AC_SUBST(SOABI)
  AC_MSG_CHECKING(ABIFLAGS)
  AC_MSG_RESULT($ABIFLAGS)
  AC_MSG_CHECKING(SOABI)
index 338892d883dd0a45d37465a148b97a6511eafb17..a9fead1d0faf38416cd82c3b06ea9f0bca405892 100644 (file)
@@ -20,7 +20,7 @@
          abi=sys.abiflags,
 --- a/Makefile.pre.in
 +++ b/Makefile.pre.in
-@@ -1555,7 +1555,7 @@ libinstall:      build_all $(srcdir)/Modules/
+@@ -1554,7 +1554,7 @@ libinstall:      build_all $(srcdir)/Modules/
                        esac; \
                done; \
        done
@@ -29,7 +29,7 @@
                $(DESTDIR)$(LIBDEST); \
        $(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
  ifeq (@COMPILE_ALL_TESTS@,yes)
-@@ -1713,7 +1713,7 @@ sharedinstall: sharedmods
+@@ -1712,7 +1712,7 @@ sharedinstall: sharedmods
                --install-scripts=$(BINDIR) \
                --install-platlib=$(DESTSHARED) \
                --root=$(DESTDIR)/
@@ -49,7 +49,7 @@
      fi
  elif test "$cross_compiling" = maybe; then
      as_fn_error $? "Cross compiling required --host=HOST-TUPLE and --build=ARCH" "$LINENO" 5
-@@ -15460,7 +15460,7 @@ fi
+@@ -15531,7 +15531,7 @@ fi
  
  
  
@@ -69,7 +69,7 @@
      fi
  elif test "$cross_compiling" = maybe; then
      AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH])
-@@ -4858,7 +4858,7 @@ fi],
+@@ -4865,7 +4865,7 @@ fi],
  
  dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
  AC_SUBST(PY_ENABLE_SHARED)
index cfca3236f2df5d9a975cd1a96cf9b496c87817b8..30aada2466aed056c7422ec0a750b8d7774435b2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.pre.in
 +++ b/Makefile.pre.in
-@@ -1607,7 +1607,7 @@ python-config: $(srcdir)/Misc/python-con
+@@ -1606,7 +1606,7 @@ python-config: $(srcdir)/Misc/python-con
        @ # On Darwin, always use the python version of the script, the shell
        @ # version doesn't use the compiler customizations that are provided
        @ # in python (_osx_support.py).