socat: Fix compile with deprecated APIs disabled
authorRosen Penev <rosenp@gmail.com>
Sun, 11 Nov 2018 01:25:29 +0000 (17:25 -0800)
committerRosen Penev <rosenp@gmail.com>
Sun, 11 Nov 2018 01:26:56 +0000 (17:26 -0800)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/socat/Makefile
net/socat/patches/200-openssl-deprecated.patch [new file with mode: 0644]

index be57601071994202428f126834a9e15735b953b2..00e95f0d17ead07fa985fe905271bc21fa554673 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=socat
 PKG_VERSION:=1.7.3.2
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download
diff --git a/net/socat/patches/200-openssl-deprecated.patch b/net/socat/patches/200-openssl-deprecated.patch
new file mode 100644 (file)
index 0000000..07c9e5b
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/xio-openssl.c b/xio-openssl.c
+index e931983..84ec100 100644
+--- a/xio-openssl.c
++++ b/xio-openssl.c
+@@ -8,6 +8,8 @@
+ #if WITH_OPENSSL      /* make this address configure dependend */
+ #include <openssl/conf.h>
+ #include <openssl/x509v3.h>
++#include <openssl/dh.h>
++#include <openssl/bn.h>
+ #include "xioopen.h"