libftdi1: Partially add back InstallDev
authorRosen Penev <rosenp@gmail.com>
Mon, 16 Sep 2019 17:44:38 +0000 (10:44 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 16 Sep 2019 17:44:38 +0000 (10:44 -0700)
The pkgconfig file needs changing.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libftdi1/Makefile

index 8b54d2ded28148c8183518c6ac7bc97e0d787ce1..f0ebf02d0d1809c4d59897cfe7e010b73157c32b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libftdi1
 PKG_VERSION:=1.4
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.intra2net.com/en/developer/libftdi/download/
@@ -64,6 +64,12 @@ CMAKE_OPTIONS += \
        -DBUILD_TESTS=OFF \
        -DEXAMPLES=OFF
 
+define Build/InstallDev
+       $(call Build/InstallDev/cmake,$(1))
+       $(SED) 's,/usr/include,$$$${prefix}/include,g' $(1)/usr/lib/pkgconfig/libftdi1.pc
+       $(SED) 's,/usr/lib,$$$${prefix}/lib,g' $(1)/usr/lib/pkgconfig/libftdi1.pc
+endef
+
 define Package/libftdi1/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libftdi1-config $(1)/usr/bin/