golang: Update to 1.19.5
authorTianling Shen <cnsztl@immortalwrt.org>
Wed, 11 Jan 2023 03:36:27 +0000 (11:36 +0800)
committerTianling Shen <cnsztl@immortalwrt.org>
Mon, 16 Jan 2023 08:24:47 +0000 (16:24 +0800)
Go1.19.5 (released 2023-01-10) includes fixes to the compiler,
the linker, and the crypto/x509, net/http, sync/atomic,
and syscall packages.

Removed upstreamed patch.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
(cherry picked from commit 5a25a731c615bb50ef6b262818c6ee2379eb0b87)

lang/golang/golang/Makefile
lang/golang/golang/patches/010-cmd-compile-turn-off-jump-tables-when-spectre-retpolines-.patch [deleted file]

index a21724f59f1991af3532cb9c9d93b3d0b82db9e4..0d779064f6707dbdf21a61c04eb80c3e1167e881 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 GO_VERSION_MAJOR_MINOR:=1.19
-GO_VERSION_PATCH:=4
+GO_VERSION_PATCH:=5
 
 PKG_NAME:=golang
 PKG_VERSION:=$(GO_VERSION_MAJOR_MINOR)$(if $(GO_VERSION_PATCH),.$(GO_VERSION_PATCH))
@@ -20,7 +20,7 @@ GO_SOURCE_URLS:=https://dl.google.com/go/ \
 
 PKG_SOURCE:=go$(PKG_VERSION).src.tar.gz
 PKG_SOURCE_URL:=$(GO_SOURCE_URLS)
-PKG_HASH:=eda74db4ac494800a3e66ee784e495bfbb9b8e535df924a8b01b1a8028b7f368
+PKG_HASH:=8e486e8e85a281fc5ce3f0bedc5b9d2dbf6276d7db0b25d3ec034f313da0375f
 
 PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
 PKG_LICENSE:=BSD-3-Clause
diff --git a/lang/golang/golang/patches/010-cmd-compile-turn-off-jump-tables-when-spectre-retpolines-.patch b/lang/golang/golang/patches/010-cmd-compile-turn-off-jump-tables-when-spectre-retpolines-.patch
deleted file mode 100644 (file)
index 1899571..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-From 156578067111742b55718066c91b8ec66d35e03d Mon Sep 17 00:00:00 2001
-From: Keith Randall <khr@golang.org>
-Date: Mon, 5 Dec 2022 16:26:26 -0800
-Subject: [PATCH] [release-branch.go1.19] cmd/compile: turn off jump tables
- when spectre retpolines are on
-
-Fixes #57100
-
-Change-Id: I6ab659abbca1ae0ac8710674d39aec116fab0baa
-Reviewed-on: https://go-review.googlesource.com/c/go/+/455336
-Reviewed-by: Keith Randall <khr@google.com>
-Reviewed-by: Cherry Mui <cherryyz@google.com>
-TryBot-Result: Gopher Robot <gobot@golang.org>
-Run-TryBot: Keith Randall <khr@golang.org>
-(cherry picked from commit 1eb0465fa596a2d6e9c1a632499989544f0d7e68)
-Reviewed-on: https://go-review.googlesource.com/c/go/+/455416
-Reviewed-by: Michael Pratt <mpratt@google.com>
----
- src/cmd/compile/internal/walk/switch.go |  2 +-
- test/codegen/retpoline.go               | 28 +++++++++++++++++++++++++
- 2 files changed, 29 insertions(+), 1 deletion(-)
-
---- a/src/cmd/compile/internal/walk/switch.go
-+++ b/src/cmd/compile/internal/walk/switch.go
-@@ -289,7 +289,7 @@ func (s *exprSwitch) tryJumpTable(cc []e
-       const minCases = 8   // have at least minCases cases in the switch
-       const minDensity = 4 // use at least 1 out of every minDensity entries
--      if !go119UseJumpTables || base.Flag.N != 0 || !ssagen.Arch.LinkArch.CanJumpTable {
-+      if !go119UseJumpTables || base.Flag.N != 0 || !ssagen.Arch.LinkArch.CanJumpTable || base.Ctxt.Retpoline {
-               return false
-       }
-       if len(cc) < minCases {
---- a/test/codegen/retpoline.go
-+++ b/test/codegen/retpoline.go
-@@ -12,3 +12,31 @@ func CallInterface(x interface{ M() }) {
-       // amd64:`CALL\truntime.retpoline`
-       x.M()
- }
-+
-+// Check to make sure that jump tables are disabled
-+// when retpoline is on. See issue 57097.
-+func noJumpTables(x int) int {
-+      switch x {
-+      case 0:
-+              return 0
-+      case 1:
-+              return 1
-+      case 2:
-+              return 2
-+      case 3:
-+              return 3
-+      case 4:
-+              return 4
-+      case 5:
-+              return 5
-+      case 6:
-+              return 6
-+      case 7:
-+              return 7
-+      case 8:
-+              return 8
-+      case 9:
-+              return 9
-+      }
-+      return 10
-+}