golang: update to 1.10.3, add mirrors
authorJeffery To <jeffery.to@gmail.com>
Fri, 22 Jun 2018 23:06:54 +0000 (07:06 +0800)
committerYousong Zhou <yszhou4tech@gmail.com>
Wed, 27 Jun 2018 03:35:48 +0000 (11:35 +0800)
This also changes the bootstrap source URL to the official GitHub
mirror, to make building easier for places where Google sites aren't
accessible. Fixes #6326.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/golang/golang-version.mk
lang/golang/golang/Makefile

index 01b429508e50ecf80b55a1e5daf56e88281f0b6c..27184b7d9a319c2daca23c122ce1551266553026 100644 (file)
@@ -11,4 +11,4 @@ endif
 
 
 GO_VERSION_MAJOR_MINOR:=1.10
-GO_VERSION_PATCH:=
+GO_VERSION_PATCH:=3
index 08170126753a53c1d0244b0b38faa57f045abe7f..7bbce4fc516d33dd556acb3930259fc6559f653a 100644 (file)
@@ -13,8 +13,13 @@ PKG_VERSION:=$(GO_VERSION_MAJOR_MINOR)$(if $(GO_VERSION_PATCH),.$(GO_VERSION_PAT
 PKG_RELEASE:=1
 
 PKG_SOURCE:=go$(PKG_VERSION).src.tar.gz
-PKG_SOURCE_URL:=https://golang.org/dl/
-PKG_HASH:=f3de49289405fda5fd1483a8fe6bd2fa5469e005fd567df64485c4fa000c7f24
+PKG_SOURCE_URL:=https://golang.org/dl/ \
+                https://dl.google.com/go/ \
+                https://fossies.org/linux/misc/ \
+                http://distfiles.gentoo.org/distfiles/ \
+                https://ftp.netbsd.org/pub/pkgsrc/distfiles/ \
+                https://distfiles.macports.org/go/
+PKG_HASH:=567b1cc66c9704d1c019c50bef946272e911ec6baf244310f87f4e678be155f2
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
@@ -52,7 +57,7 @@ HOST_GO_VALID_OS_ARCH:= \
   linux_ppc64 linux_ppc64le linux_mips linux_mipsle linux_mips64 linux_mips64le
 
 BOOTSTRAP_SOURCE_PROTO:=git
-BOOTSTRAP_SOURCE_URL:=https://go.googlesource.com/go
+BOOTSTRAP_SOURCE_URL:=https://github.com/golang/go.git
 BOOTSTRAP_SOURCE_VERSION:=4d5426a570c2820c5894a61b52e3dc147e4e7925
 BOOTSTRAP_SOURCE_DATE:=20170926
 BOOTSTRAP_MIRROR_HASH:=a3e26ee7c96486c841d29cbea3bf548ce2d999b9235275091cbe60ae6efa4cb1