python3-dockerpty: add a new package
authorJavier Marcet <javier@marcet.info>
Mon, 2 Mar 2020 15:01:13 +0000 (16:01 +0100)
committerJavier Marcet <javier@marcet.info>
Mon, 8 Jun 2020 11:49:06 +0000 (13:49 +0200)
Signed-off-by: Javier Marcet <javier@marcet.info>
lang/python/python-dockerpty/Makefile [new file with mode: 0644]

diff --git a/lang/python/python-dockerpty/Makefile b/lang/python/python-dockerpty/Makefile
new file mode 100644 (file)
index 0000000..6425727
--- /dev/null
@@ -0,0 +1,36 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-dockerpty
+PKG_VERSION:=0.4.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=dockerpty
+PKG_HASH:=69a9d69d573a0daa31bcd1c0774eeed5c15c295fe719c61aca550ed1393156ce
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE.txt
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+PYTHON3_PKG_SETUP_ARGS:=
+
+define Package/python3-dockerpty
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  TITLE:=Python library to use the pseudo-tty of a docker container
+  URL:=https://github.com/d11wtq/dockerpty
+  DEPENDS:=+python3-light +python3-docker +python3-six
+  VARIANT:=python3
+endef
+
+define Package/python3-dockerpty/description
+  Python library to use the pseudo-tty of a docker container
+endef
+
+$(eval $(call Py3Package,python3-dockerpty))
+$(eval $(call BuildPackage,python3-dockerpty))
+$(eval $(call BuildPackage,python3-dockerpty-src))