node-cylon: copy files, not symlinks
authorEneas U de Queiroz <cote2004-github@yahoo.com>
Fri, 7 Dec 2018 17:18:40 +0000 (15:18 -0200)
committerEneas U de Queiroz <cote2004-github@yahoo.com>
Fri, 7 Dec 2018 17:22:53 +0000 (15:22 -0200)
This was meant to be included in 56fe558, but wasn't.
Current version of npm install installs a link to the build directory.
The workaround is to use npm pack to make a tarball and install from
that.

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
lang/node-cylon/Makefile

index 8ac664c66bd25402785550e7ecebb5702c47e93d..6e2fa3c58554b72cbdaf176e8d5fbe332e7b91d2 100644 (file)
@@ -65,12 +65,13 @@ endef
 EXTRA_LDFLAGS="-L$(TOOLCHAIN_DIR)/lib/ -Wl,-rpath-link $(TOOLCHAIN_DIR)/lib/" \
 
 define Build/Compile
+       cd $(PKG_BUILD_DIR) ; \
        $(MAKE_FLAGS) \
        npm_config_arch=$(CONFIG_ARCH) \
        npm_config_nodedir=$(BUILD_DIR)/node-$(PKG_NODE_VERSION)/ \
        npm_config_cache=$(BUILD_DIR)/node-$(PKG_NODE_VERSION)/npm-cache \
        PREFIX="$(PKG_INSTALL_DIR)/usr/" \
-       npm install -g $(PKG_BUILD_DIR)
+       npm install -g `npm pack $(PKG_BUILD_DIR) | tail -n 1`
 endef
 
 define Package/node-cylon/install