imagebuilder: fix OPKG package_whatdepends support
authorRobert Marko <robimarko@gmail.com>
Tue, 19 Nov 2024 22:56:19 +0000 (23:56 +0100)
committerRobert Marko <robimarko@gmail.com>
Wed, 20 Nov 2024 08:49:57 +0000 (09:49 +0100)
Trying to use 'package_whatdepends' feature of the ImageBuilder with OPKG
will currently fail as OPKG does not support "list --depends" call at all,
it seems that this is a mixup from the original APK support commit.

So, lets restore 'package_whatdepends' support for OPKG by calling
"whatdepends -A" instead as we used to before APK support.

Fixes: d788ab376f85 ("build: add APK package build capabilities")
Link: https://github.com/openwrt/openwrt/pull/17022
Signed-off-by: Robert Marko <robimarko@gmail.com>
(cherry picked from commit 52519a59a859d349f154ed79e0a3d63457b6aa6a)

target/imagebuilder/files/Makefile

index f46b61b7870670692176f0dc9f1b343d29a3a88e..54bc61284072895665dc7dab1d86262dc169ccae 100644 (file)
@@ -352,7 +352,7 @@ ifeq ($(PACKAGE),)
 endif
        @$(MAKE) -s package_reload
 ifeq ($(CONFIG_USE_APK),)
-       @$(OPKG) list --depends $(PACKAGE)
+       @$(OPKG) whatdepends -A $(PACKAGE)
 else
        @$(APK) list --depends $(PACKAGE)
 endif