python3-pip: fix install rule
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 27 Feb 2019 10:18:17 +0000 (12:18 +0200)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 27 Feb 2019 10:18:19 +0000 (12:18 +0200)
Fixes: https://github.com/openwrt/packages/issues/8301
This seems to have slipped for some time. No idea if it ever worked.
It could be that this worked at some point.

In any case, the shebang is properly updated now.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/python3/files/python3-package-pip.mk

index fd1cd59d54767c851eab382edd3d15c36a881ad1..677f61efa30eae70af2800ed7f3ca1fe14e55c4f 100644 (file)
@@ -12,7 +12,7 @@ $(call Package/python3/Default)
   DEPENDS:=+python3 +python3-setuptools +python-pip-conf
 endef
 
-define Package/python3-pip/install
+define Py3Package/python3-pip/install
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/python$(PYTHON3_VERSION)/site-packages
        $(CP) $(PKG_BUILD_DIR)/install-pip/bin/pip3* $(1)/usr/bin
        $(CP) \