ramips: mt7621: add support for Confiabits MT7621 v1
authorLuis Mita <luis@luismita.com>
Wed, 8 Jan 2025 22:10:04 +0000 (18:10 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 14 Jan 2025 22:35:04 +0000 (23:35 +0100)
Hardware:
 - SoC: MediaTek MT7621DAT
 - Flash: 16 MiB cFeon
 - RAM: 128 MiB MT7621DAT
 - WLAN: 2.4 GHz (MT7603EN), 5 GHz (MT7613BEN 802.11ac)
 - Ethernet: 1x 10/100/1000 Mbps WAN, 3x 10/100/1000 LAN (MT7621DAT)
 - Buttons: 1 Reset button, 1 WPS button
 - LEDs: 5x Green (POWER/WAN/2.4G/5G/WPS), 1x Red (WAN)
 - Serial console: unpopulated header, 57600 8n1
 - Power: 12 VDC, 1 A

MAC:
LAN MAC: label mac (eeprom@4)
WAN MAC: label mac (eeprom@4)
2.4G MAC: label mac (eeprom@4)
5G MAC: label mac + 1 (eeprom@8004)

Installation:
The stock firmware is OpenWrt-based. If you can reach LuCI or SSH, just use the sysupgrade image
with the 'Keep settings' option turned off.

Signed-off-by: Luis Mita <luis@luismita.com>
Link: https://github.com/openwrt/openwrt/pull/17534
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/ramips/dts/mt7621_confiabits_mt7621-v1.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
target/linux/ramips/mt7621/base-files/etc/board.d/02_network

diff --git a/target/linux/ramips/dts/mt7621_confiabits_mt7621-v1.dts b/target/linux/ramips/dts/mt7621_confiabits_mt7621-v1.dts
new file mode 100644 (file)
index 0000000..858747e
--- /dev/null
@@ -0,0 +1,215 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/leds/common.h>
+
+/ {
+       compatible = "confiabits,mt7621-v1", "mediatek,mt7621-soc";
+       model = "Confiabits MT7621 v1";
+
+       aliases {
+               led-boot = &led_power_green;
+               led-failsafe = &led_power_green;
+               led-running = &led_power_green;
+               led-upgrade = &led_power_green;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               button-wps {
+                       label = "wps";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+
+               button-reset {
+                       label = "reset";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power_green: led-power-green {
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_POWER;
+                       gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+               };
+
+               led-wan-red {
+                       color = <LED_COLOR_ID_RED>;
+                       function = LED_FUNCTION_WAN;
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+               };
+
+               led-wlan5 {
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_WLAN_5GHZ;
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+
+               led-wps {
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_WPS;
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+
+               led-wlan24 {
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_WLAN_2GHZ;
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               led-wan-green {
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_WAN;
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <40000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "radio";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+
+                               nvmem-layout {
+                                       compatible = "fixed-layout";
+                                       #address-cells = <1>;
+                                       #size-cells = <1>;
+
+                                       eeprom_radio_0: eeprom@0 {
+                                               reg = <0x0 0x400>;
+                                       };
+
+                                       eeprom_radio_8000: eeprom@8000 {
+                                               reg = <0x8000 0x4da8>;
+                                       };
+
+                                       macaddr_radio_4: macaddr@4 {
+                                               reg = <0x4 0x6>;
+                                       };
+
+                                       macaddr_radio_8004: macaddr@8004 {
+                                               reg = <0x8004 0x6>;
+                                       };
+                               };
+                       };
+
+                       partition@50000 {
+                               label = "firmware";
+                               compatible = "denx,uimage";
+                               reg = <0x50000 0xfb0000>;
+                       };
+               };
+       };
+};
+
+&gmac0 {
+       nvmem-cells = <&macaddr_radio_4>;
+       nvmem-cell-names = "mac-address";
+};
+
+&gmac1 {
+       status = "okay";
+       label = "wan";
+       phy-handle = <&ethphy4>;
+
+       nvmem-cells = <&macaddr_radio_4>;
+       nvmem-cell-names = "mac-address";
+};
+
+&ethphy4 {
+       /delete-property/ interrupts;
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               ieee80211-freq-limit = <2400000 2500000>;
+
+               nvmem-cells = <&eeprom_radio_0>;
+               nvmem-cell-names = "eeprom";
+       };
+};
+
+&pcie1 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               ieee80211-freq-limit = <5000000 6000000>;
+
+               nvmem-cells = <&eeprom_radio_8000>;
+               nvmem-cell-names = "eeprom";
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "i2c", "jtag", "wdt";
+               function = "gpio";
+       };
+};
+
+&switch0 {
+       ports {
+               port@0 {
+                       status = "okay";
+                       label = "lan1";
+               };
+
+               port@1 {
+                       status = "okay";
+                       label = "lan2";
+               };
+
+               port@2 {
+                       status = "okay";
+                       label = "lan3";
+               };
+       };
+};
index aa38495224c5f1111d5746b17702808d90bb457c..08b3dcc64f752d8f1792bfca81c8b1838df56058 100755 (executable)
@@ -687,6 +687,18 @@ define Device/comfast_cf-ew72-v2
 endef
 TARGET_DEVICES += comfast_cf-ew72-v2
 
+define Device/confiabits_mt7621-v1
+  $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
+  IMAGE_SIZE := 16064k
+  DEVICE_VENDOR := Confiabits
+  DEVICE_MODEL := MT7621
+  DEVICE_VARIANT := v1
+  DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap \
+       -uboot-envtools
+endef
+TARGET_DEVICES += confiabits_mt7621-v1
+
 define Device/cudy_m1800
   $(Device/dsa-migration)
   DEVICE_VENDOR := Cudy
index ec452ccd944762bc762f5dae2ceff232f84f083d..1542eed8f62e2c34d7d32e1259486b109d127cac 100644 (file)
@@ -58,6 +58,10 @@ wifire,s1500-nbn)
 belkin,rt1800)
        ucidef_set_led_netdev "wan" "wan" "white:wan" "wan"
        ;;
+confiabits,mt7621-v1|\
+netis,n6)
+       ucidef_set_led_netdev "wan" "wan" "green:wan" "wan" "link tx rx"
+       ;;
 cudy,wr2100)
        ucidef_set_led_netdev "lan1" "lan1" "green:lan1" "lan1"
        ucidef_set_led_netdev "lan2" "lan2" "green:lan2" "lan2"
@@ -189,9 +193,6 @@ netgear,r7450)
 netgear,wax202)
        ucidef_set_led_netdev "internet" "Internet" "green:net" "wan"
        ;;
-netis,n6)
-       ucidef_set_led_netdev "wan" "wan" "green:wan" "wan" "link tx rx"
-       ;;
 oraybox,x3a)
        ucidef_set_led_netdev "wan" "wan link" "red:status" "wan"
        ucidef_set_led_netdev "lan" "lan link" "green:status" "br-lan"
index c780443c1c58de416cb353f56d922946961f52be..f40e9616d019e2ce97f6b4e101ef7dcb74710f55 100644 (file)
@@ -13,6 +13,7 @@ ramips_setup_interfaces()
        asus,rt-ax53u|\
        buffalo,wsr-2533dhpl2|\
        buffalo,wsr-2533dhpls|\
+       confiabits,mt7621-v1|\
        gehua,ghl-r-001|\
        h3c,tx1800-plus|\
        h3c,tx1801-plus|\