python-tomli: Remove package
authorJeffery To <jeffery.to@gmail.com>
Thu, 25 May 2023 18:06:57 +0000 (02:06 +0800)
committerJeffery To <jeffery.to@gmail.com>
Sat, 27 May 2023 08:51:02 +0000 (16:51 +0800)
Python added tomli to its standard library in 3.11. Now that Python in
the packages feed has been updated to 3.11, the separate tomli package
is no longer necessary.

This removes python-tomli and updates all dependant packages, removing
python-tomli from their lists of dependencies.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
(cherry picked from commit 0509d460c844c2f62d09fd99c35a0e1627c66b68)

lang/python/python-build/Makefile
lang/python/python-flit-scm/Makefile
lang/python/python-hatch-fancy-pypi-readme/Makefile
lang/python/python-hatchling/Makefile
lang/python/python-pyproject-hooks/Makefile
lang/python/python-pytest/Makefile
lang/python/python-setuptools-scm/Makefile
lang/python/python-tomli/Makefile [deleted file]

index e60023725e4b307a5ef439d25ba41985474c35bb..e93025a6319c9b58d65d0e1f7376101e7312a0cc 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-build
 PKG_VERSION:=0.10.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PYPI_NAME:=build
 PKG_HASH:=d5b71264afdb5951d6704482aac78de887c80691c52b88a9ad195983ca2c9269
@@ -24,8 +24,7 @@ HOST_BUILD_DEPENDS:= \
        python-installer/host \
        python-flit-core/host \
        python-packaging/host \
-       python-pyproject-hooks/host \
-       python-tomli/host
+       python-pyproject-hooks/host
 
 PYTHON3_HOST_BUILD_VARS:=PYTHONPATH=src
 
index 57660f79bb28e085ce210ce83593338f697f32c0..87188fd743af0ea491e92a84d749ee5e7d640427 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-flit-scm
 PKG_VERSION:=1.7.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PYPI_NAME:=flit-scm
 PYPI_SOURCE_NAME:=flit_scm
@@ -25,8 +25,7 @@ HOST_BUILD_DEPENDS:= \
        python-build/host \
        python-installer/host \
        python-flit-core/host \
-       python-setuptools-scm/host \
-       python-tomli/host
+       python-setuptools-scm/host
 
 include ../pypi.mk
 include $(INCLUDE_DIR)/package.mk
@@ -40,7 +39,7 @@ define Package/python3-flit-scm
   SUBMENU:=Python
   TITLE:=A PEP 518 build backend that uses setuptools_scm and flit
   URL:=https://gitlab.com/WillDaSilva/flit_scm
-  DEPENDS:=+python3-light +python3-flit-core +python3-setuptools-scm +python3-tomli
+  DEPENDS:=+python3-light +python3-flit-core +python3-setuptools-scm
   BUILDONLY:=1
 endef
 
index 4a2ab871d38816a4ed09fa487222d35de3502b02..24e27be36c0daf097f4bdc6f342136fe8544a9ba 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-hatch-fancy-pypi-readme
 PKG_VERSION:=22.8.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PYPI_NAME:=hatch-fancy-pypi-readme
 PYPI_SOURCE_NAME:=hatch_fancy_pypi_readme
@@ -20,12 +20,7 @@ PKG_LICENSE_FILES:=LICENSE.txt
 PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
 
 PKG_HOST_ONLY:=1
-HOST_BUILD_DEPENDS:= \
-       python3/host \
-       python-build/host \
-       python-installer/host \
-       python-hatchling/host \
-       python-tomli/host
+HOST_BUILD_DEPENDS:=python3/host python-build/host python-installer/host python-hatchling/host
 
 include ../pypi.mk
 include $(INCLUDE_DIR)/package.mk
@@ -39,7 +34,7 @@ define Package/python3-hatch-fancy-pypi-readme
   SUBMENU:=Python
   TITLE:=Fancy PyPI READMEs with Hatch
   URL:=https://github.com/hynek/hatch-fancy-pypi-readme
-  DEPENDS:=+python3-light +python3-hatchling +python3-tomli
+  DEPENDS:=+python3-light +python3-hatchling
   BUILDONLY:=1
 endef
 
index 76ca4fc1a14686c0989c2b0e6ea0507321264c24..6bc1b8fbcbe5cfac7a465039fc3bbf95778e6ffa 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-hatchling
 PKG_VERSION:=1.17.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PYPI_NAME:=hatchling
 PKG_HASH:=b1244db3f45b4ef5a00106a46612da107cdfaf85f1580b8e1c059fefc98b0930
@@ -27,7 +27,6 @@ HOST_BUILD_DEPENDS:= \
        python-packaging/host \
        python-pathspec/host \
        python-pluggy/host \
-       python-tomli/host \
        python-trove-classifiers/host
 
 include ../pypi.mk
@@ -49,7 +48,6 @@ define Package/python3-hatchling
       +python3-packaging \
       +python3-pathspec \
       +python3-pluggy \
-      +python3-tomli \
       +python3-trove-classifiers
   BUILDONLY:=1
 endef
index 50b3780ede5fdcc0895e8c6bac713480c601de4d..316a8026dbd8ee7e684484234e084627d767f596 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-pyproject-hooks
 PKG_VERSION:=1.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PYPI_NAME:=pyproject_hooks
 PKG_HASH:=f271b298b97f5955d53fb12b72c1fb1948c22c1a6b70b315c54cedaca0264ef5
@@ -19,7 +19,7 @@ PKG_LICENSE_FILES:=LICENSE
 PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
 
 PKG_HOST_ONLY:=1
-HOST_BUILD_DEPENDS:=python3/host python-flit-core/host python-installer/host python-tomli/host
+HOST_BUILD_DEPENDS:=python3/host python-flit-core/host python-installer/host
 
 include ../pypi.mk
 include $(INCLUDE_DIR)/package.mk
index dd978d248f8c884fc43f30a954095aec14181159..473192c312266f252412b96a57d50b1e7941f8c6 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-pytest
 PKG_VERSION:=7.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PYPI_NAME:=pytest
 PKG_HASH:=58ecc27ebf0ea643ebfdf7fb1249335da761a00c9f955bcd922349bcb68ee57d
@@ -34,7 +34,6 @@ define Package/python3-pytest
        +python3 \
        +python3-pluggy \
        +python3-packaging \
-       +python3-tomli \
        +python3-exceptiongroup \
        +python3-iniconfig
 endef
index c9a0ec78d96100868e6e4ab53d7425f6f928b60d..5e197a57f9af6e2dff5632de522b139b8e803ac1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-setuptools-scm
 PKG_VERSION:=7.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PYPI_NAME:=setuptools-scm
 PYPI_SOURCE_NAME:=setuptools_scm
@@ -26,7 +26,6 @@ HOST_BUILD_DEPENDS:= \
        python-installer/host \
        python-wheel/host \
        python-packaging/host \
-       python-tomli/host \
        python-typing-extensions/host
 
 include ../pypi.mk
@@ -46,7 +45,6 @@ define Package/python3-setuptools-scm
       +python3-logging \
       +python3-packaging \
       +python3-setuptools \
-      +python3-tomli \
       +python3-typing-extensions
   BUILDONLY:=1
 endef
diff --git a/lang/python/python-tomli/Makefile b/lang/python/python-tomli/Makefile
deleted file mode 100644 (file)
index db615e3..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-#
-# Copyright (C) 2023 Jeffery To
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python-tomli
-PKG_VERSION:=2.0.1
-PKG_RELEASE:=1
-
-PYPI_NAME:=tomli
-PKG_HASH:=de526c12914f0c550d15924c62d72abc48d6fe7364aa87328337a31007fe8a4f
-
-PKG_LICENSE:=MIT
-PKG_LICENSE_FILES:=LICENSE
-PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
-
-PKG_HOST_ONLY:=1
-HOST_BUILD_DEPENDS:=python3/host python-flit-core/host python-installer/host
-
-include ../pypi.mk
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/host-build.mk
-include ../python3-package.mk
-include ../python3-host-build.mk
-
-define Package/python3-tomli
-  SECTION:=lang
-  CATEGORY:=Languages
-  SUBMENU:=Python
-  TITLE:=A lil' TOML parser
-  URL:=https://github.com/hukkin/tomli
-  DEPENDS:=+python3-light
-  BUILDONLY:=1
-endef
-
-define Package/python3-tomli/description
-Tomli is a Python library for parsing TOML. Tomli is fully compatible
-with TOML v1.0.0.
-endef
-
-Host/Compile=$(Py3Host/Compile/Bootstrap)
-
-$(eval $(call Py3Package,python3-tomli))
-$(eval $(call BuildPackage,python3-tomli))
-$(eval $(call BuildPackage,python3-tomli-src))
-$(eval $(call HostBuild))