alpine: try to make reproducible
authorRosen Penev <rosenp@gmail.com>
Wed, 3 Feb 2021 06:33:59 +0000 (22:33 -0800)
committerRosen Penev <rosenp@gmail.com>
Wed, 3 Feb 2021 06:38:12 +0000 (22:38 -0800)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
mail/alpine/Makefile
mail/alpine/patches/020-reproducible.patch [new file with mode: 0644]

index 909e659c26c562ec2a8460e8f86eb7dc1e098bc1..6d6cbeccb427dcb4147af5b1725483ea6a827d86 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=alpine
 PKG_VERSION:=2.24
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://alpine.x10host.com/alpine/release/src
diff --git a/mail/alpine/patches/020-reproducible.patch b/mail/alpine/patches/020-reproducible.patch
new file mode 100644 (file)
index 0000000..97efdd5
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/pico/blddate.c
++++ b/pico/blddate.c
+@@ -28,6 +28,7 @@ main(argc, argv)
+       exit(1);
+     }
++/*
+     time(&ltime);
+     t = localtime(&ltime);
+     fprintf(outfile,"char datestamp[]=\"%02d-%s-%d\";\n", t->tm_mday, 
+@@ -46,6 +47,7 @@ main(argc, argv)
+           1900 + t->tm_year);
+     fprintf(outfile, "char hoststamp[]=\"random-pc\";\n");
++*/
+     fprintf(outfile, "char configoptions[] = \"\";\n");
+     fclose(outfile);