knot-resolver: change scheduling priority
authorJan Pavlinec <jan.pavlinec@nic.cz>
Thu, 17 Jun 2021 12:59:32 +0000 (14:59 +0200)
committerJan Pavlinec <jan.pavlinec@nic.cz>
Thu, 17 Jun 2021 13:00:48 +0000 (15:00 +0200)
This should prevent some resolving issues by other router app.

Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
net/knot-resolver/Makefile
net/knot-resolver/files/kresd.init

index 89db36fb011d71d54457229e1b58956544355745..dc215d4dd81f285de8104e0781563e33f738bfba 100644 (file)
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=knot-resolver
 PKG_VERSION:=5.3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-resolver
index 18f09e18ca194fee2a93d96780c7f3765710d536..9642c9d76a93504a670c9906814ee85b3c8521a8 100755 (executable)
@@ -65,6 +65,7 @@ start_service() {
        procd_append_param command -c "$CONFIGFILE"
        procd_append_param command -a "0.0.0.0#53"
        procd_append_param command -a "::0#53"
+       procd_set_param nice '-5'
        procd_close_instance
 }